MakeMKV 1.14.1 doesn't see network drives on Win10

Everything related to MakeMKV
Post Reply
Mathman85
Posts: 1
Joined: Mon Nov 12, 2018 10:41 pm

MakeMKV 1.14.1 doesn't see network drives on Win10

Post by Mathman85 » Mon Nov 12, 2018 10:46 pm

Hello! I just updated to 1.14.1, and now the software does not recognize any of my network drives that I use for storage. It says my default location doesn't exist, but the drive is mapped and shows up in Windows Explorer; it also doesn't show any network locations if I browse to the folder I want to save the files in.

Since I use my NAS for media storage, this has created an inconvenience. Is this problem unique to me or is anybody else experiencing the same?

Woodstock
Posts: 6412
Joined: Sun Jul 24, 2011 11:21 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by Woodstock » Tue Nov 13, 2018 2:07 am

Do you access the NAS as a "shared drive" resource (mount it as a drive letter) or use direct network addressing, such as \\nas\rawvid ?

All of my ripping is done to a NAS (Synology), and 1.14.x has worked for that, but I map the raw video as drive Z: on all my machines. I'd have to get my laptop out to test it with Win10 (I do not normally allow Win10 attach to any important network), but both methods work on Windows 7 with 1.14.1.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

Stephen19
Posts: 3
Joined: Wed Nov 14, 2018 4:08 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by Stephen19 » Wed Nov 14, 2018 4:25 pm

I'm fairly new to MakrMKV but I found with the last 2 updates that Windows 10 would not connect to my NAS drive immediately after updating. On both occasions I had used the "Start MKV" option at the end of the install process.

I use a limited rights user in Windows 10 and when I tried to browse to my NAS from within MakMKV it was asking for a username and password. That was strange because if I used Windows Explorer, I could browse the NAS with no issues. Because MakeMKV could not get to the NAS it reset its default paths which are normally pointing to the NAS.

It's as if MakeMKV is using an incorrect username and password when trying to connect to the nas drive but only the first time a new version runs.

To resolve this issue I quit MakeMKV and started it again. The second time it started after each update it was able to connect to the NAS drive with no problems.

You mention that you have "just updated" so I suspect you may have the same issue. Try quitting MakeMKV and starting it again to see if this solves the issue. Failing that try restarting your PC to see if this resolves the issue.

I hope this is of use.

Woodstock
Posts: 6412
Joined: Sun Jul 24, 2011 11:21 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by Woodstock » Wed Nov 14, 2018 5:54 pm

We also have the "October surprise" Win10 update that was "fixed" and re-issued this week.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

Stephen19
Posts: 3
Joined: Wed Nov 14, 2018 4:08 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by Stephen19 » Wed Nov 14, 2018 9:08 pm

I don't think that the Win10 update is the primary factor. Windows did not update in the 2-3 minutes between one version of MKV working fine and the updated version having authentication issues.

My suspicion is that the developer has accidentally hard coded the application to "run as" a specific user (possibly themselves) when launched from the "Launch MakeMKV" message at the end of the installer. My network is quite locked down so this would cause the application to be blocked from accessing any assets on the network and cause the behaviour that I have observed.

Post Reply