Problematic HD-DVDs

Everything related to MakeMKV
dpstjp
Posts: 44
Joined: Wed Dec 08, 2010 12:36 pm

Re: Problematic HD-DVDs

Post by dpstjp » Sun May 15, 2011 7:44 pm

You may find that the rip is fine.

Galapagos won't work on VLC as the video is interlaced. I suspect MPC is the same.

setarip_old
Posts: 2136
Joined: Wed Dec 09, 2009 1:31 pm

Re: Problematic HD-DVDs

Post by setarip_old » Sun May 15, 2011 8:19 pm

@billythefish

Hi!

I don't know if this may be the reason but, according to your log:
Scan type : Interlaced


Curiously though, in a review by High-Def Digest:
Video Resolution/Codec
1080p/VC-1
- indicates that the original HD-DVD is Progressive rather than interlaced...




Romansh
Posts: 872
Joined: Sat Jan 22, 2011 7:09 pm

Re: Problematic HD-DVDs

Post by Romansh » Sun May 15, 2011 10:42 pm

setarip_old wrote:@billythefish

Hi!

I don't know if this may be the reason but, according to your log:
Scan type : Interlaced


Curiously though, in a review by High-Def Digest:
Video Resolution/Codec
1080p/VC-1
- indicates that the original HD-DVD is Progressive rather than interlaced...



Highdefdigest got it wrong. The combination of the MediaInfo report and the lack of video when playing in VLC (not to mention, it's a BBC Video release) indicate that this disc uses interlaced VC-1.

setarip_old
Posts: 2136
Joined: Wed Dec 09, 2009 1:31 pm

Re: Problematic HD-DVDs

Post by setarip_old » Mon May 16, 2011 7:17 am

@Romansh

Hi!

Do you own this HD-DVD? If not, you are speculating based on the posted log - which is, itself, a log of the .MKV and not of the original HD-DVD...



Romansh
Posts: 872
Joined: Sat Jan 22, 2011 7:09 pm

Re: Problematic HD-DVDs

Post by Romansh » Mon May 16, 2011 5:28 pm

setarip_old wrote:@Romansh

Hi!

Do you own this HD-DVD? If not, you are speculating based on the posted log - which is, itself, a log of the .MKV and not of the original HD-DVD...


I am speculating indeed, but on more than just the log:

- BBC is known to use VC-1 with interlaced compression on many of their Blu-rays, so that they would do the same on HD-DVDs isn't surprising

- VLC plays audio but not video; while that doesn't mean the video is interlaced (the lack of video could be due to something else), interlaced VC-1 will cause this symptom (no video in VLC yet the audio plays fine)

- MediaInfo reports the video as being interlaced; if the video isn't using interlaced compression, that means either of the following:
- -> MediaInfo is parsing the video stream's properties incorrectly
- -> MakeMKV is somehow changing the stream's properties when ripping
- -> the stream uses progressive compression but is flagged as interlaced on the HD-DVD for some reason
all of which are possible, though based on the two other points I mentioned above, I consider them somewhat unlikely.

In any case, that's not the real issue - the issue is that the sounds plays, but the video doesn't (in VLC and MPC). Based on that log, the most likely explanation is that the stream is flagged as interlaced. Whether the libavcodec VC-1 decoder (which is used by both VLC - exclusively, unless using hardware-accelerated decoding - and MPC-HC - by default) sees this and aborts before decoding or actually tries to decode and checks if interlaced compression is really used, I don't know (you'd have to ask a libavcodec developer), but that doesn't change the end result (no video).

dpstjp
Posts: 44
Joined: Wed Dec 08, 2010 12:36 pm

Re: Problematic HD-DVDs

Post by dpstjp » Tue May 17, 2011 3:42 pm

setarip_old wrote:@Romansh

Hi!

Do you own this HD-DVD? If not, you are speculating based on the posted log - which is, itself, a log of the .MKV and not of the original HD-DVD...


I own this disc. I can confirm it's 1080i. As I said in my previous post.

setarip_old
Posts: 2136
Joined: Wed Dec 09, 2009 1:31 pm

Re: Problematic HD-DVDs

Post by setarip_old » Tue May 17, 2011 6:50 pm

@dpstjp

Hi!

Thanks for confirming...


midphase
Posts: 3
Joined: Thu Jun 03, 2010 5:40 pm

Re: Problematic HD-DVDs

Post by midphase » Thu Jun 16, 2011 6:29 am

I'm having problems with Blade Runner the Final Cut on HD DVD (the collection with a bunch of versions).

The movie seems to rip fine, but playback is choppy as hell. I tried VLC with the H.264 Loop set to All and the other suggestions mentioned on the forum in the various threads. I tried using mPlayer (I'm on Mac OSX), I have successfully ripped my entire collection of films and hardly ever experience any stuck frames on playback, but Blade Runner doesn't play back well at all and it's always in the same spots which leads me to think that something about the file that MakeMKV is producing is not quite right.

Has anyone successfully ripped and played back Blade Runner? I honestly don't know how to fix this, but if it's been mentioned on this forum chances are I tried it.

captin
Posts: 11
Joined: Thu Jun 16, 2011 5:05 pm

Re: Problematic HD-DVDs

Post by captin » Thu Jun 16, 2011 5:42 pm

Ocean?s Thirteen
Warner Bros

Fails to rip main feature, file grows to reasonable size then disappears, many other disks fine.

Debug log started at Thu Jun 16 17:07:26 2011 , written by MakeMKV v1.6.10 linux(x64-release)
Using 524544KB for read cache.
001005:0000 MakeMKV v1.6.10 linux(x64-release) started
001004:0000 Debug logging enabled, log will be saved as /home/andre/MakeMKV_log.txt
001003:0020 DEBUG: Code 0 at qb`j0Gd}T*CtIQbE4:121262164
001003:0020 DEBUG: Code 0 at qb`j0Gd}T*CtIQbE4:121262164
001003:0020 DEBUG: Code 0 at qb`j0Gd}T*CtIQbE4:121262164
001003:0020 DEBUG: Code 0 at qb`j0Gd}T*CtIQbE4:121262164
DAFD=PAAAADAAAAFABDQEEAQQBAUNPQjIwMjYgAQoADEZEQwA=
DCE=bpWPQsn3kNcVGqCaU/DenfSO7vEljeKajdTKtzPmfJsEb3RkxetjtoaJggq5zi7kOBDu6wGZhOc3Akhtw379eXuBCbdTFAcTHJbZSigMt3r+xDIRg0VX61ZLgYfb5TiS33pFiBsFGYPoqGT6Fp/4smIPd90z6SkxFw==
005011:0000 Operation successfully completed
005014:0000 Saving 1 titles into directory /home/andre/Videos/OCEANS_THIRTEEN_HD_DVD
001003:0020 DEBUG: Code 543 at wJX5{9Xp`Y(J5];Y :29395839
001002:0020 LIBMKV_TRACE: Exception: EOF in writeFully
005003:0000 Failed to save title 0 to file /home/andre/Videos/OCEANS_THIRTEEN_HD_DVD/t00_feature_01_01.mkv
005004:0080 0 titles saved, 1 failed
005037:0204 Copy complete. 0 titles saved, 1 failed.

richdmoore
Posts: 12
Joined: Wed Jun 29, 2011 2:13 pm

Re: Problematic HD-DVDs

Post by richdmoore » Wed Jun 29, 2011 2:23 pm

I'm new to this, but I have two HD-DVD's that I can't seem to get ripped. I will make a another post for the other one once I try one more time to get it to copy.

1. Carlito's Way: Rise to Power
2. Universal
3. Not Sure, Back of the insert says 1080P High-Definition Widescreen 1.85:1 Encoded VC-1
4. Not sure, Back of the insert says English Dolby TrueHD 5.1;; English, Francais, Dolby Digital Plus 5.1
5. The disc gets to the last second or two, then I get a failed message.
6: Debug Log:

MakeMKV v1.6.10 darwin(x86-release) started
Debug logging enabled, log will be saved as /Users/Rich/MakeMKV_log.txt
DEBUG: Code 3758097095 at mNR(~0Vx|!h0U~o5"F9V+HIE[~g.:29394896
Optical drive "BD-ROM TOSHIBA DVD/HD X807616 MC08" opened in OS access mode.
It's highly recommended to install DASPI kernel extension to improve performance.
Optical drive "DVD+R-DL OPTIARC DVD RW AD-5680H 3AHF" opened in OS access mode.
DEBUG: Code 3758097095 at mNR(~0Vx|!h0U~o5"F9V+HIE[~g.:29394896
DEBUG: Code 3758097095 at mNR(~0Vx|!h0U~o5"F9V+HIE[~g.:29394896
DEBUG: Code 3758097095 at mNR(~0Vx|!h0U~o5"F9V+HIE[~g.:29394896
DEBUG: Code 3758097095 at mNR(~0Vx|!h0U~o5"F9V+HIE[~g.:29394896
Evaluation version, 27 day(s) out of 30 remaining
DEBUG: Code 0 at /Vu6AYr{}1T@`E.oG:121262164
DEBUG: Code 0 at /Vu6AYr{}1T@`E.oG:121262164
DEBUG: Code 0 at /Vu6AYr{}1T@`E.oG:121262164
DEBUG: Code 0 at /Vu6AYr{}1T@`E.oG:121262164
DEBUG: Code 8 at [3]uO]t{k8cYC)l6z?:121261980
Operation successfully completed
Saving 1 titles into directory /Users/Rich/Movies/MAKEMKV
DEBUG: Code 544 at -a-8ODSZTXzsq{hz.:29395839
LIBMKV_TRACE: Exception: EOF in writeFully
Failed to save title 1 to file /Users/Rich/Movies/MAKEMKV/t01_HD_Feature.mkv
0 titles saved, 1 failed

richdmoore
Posts: 12
Joined: Wed Jun 29, 2011 2:13 pm

Re: Problematic HD-DVDs

Post by richdmoore » Wed Jun 29, 2011 2:36 pm

1. Pulse
2. Dimension
3. No idea on on video, back of insert says: High Definition WIdescreen Presentation 16x9 1080i or 108p
4. No idea on audio, back of insert says: English 5.1 French 5.1
5. Starts ripping for a couple of minutes, then stops with failed message.
6. Debug Log:

MakeMKV v1.6.10 darwin(x86-release) started
Debug logging enabled, log will be saved as /Users/Rich/MakeMKV_log.txt
DEBUG: Code 3758097095 at mNR(~0Vx|!h0U~o5"F9V+HIE[~g.:29394896
Optical drive "BD-ROM TOSHIBA DVD/HD X807616 MC08" opened in OS access mode.
It's highly recommended to install DASPI kernel extension to improve performance.
Optical drive "DVD+R-DL OPTIARC DVD RW AD-5680H 3AHF" opened in OS access mode.
DEBUG: Code 3758097095 at mNR(~0Vx|!h0U~o5"F9V+HIE[~g.:29394896
DEBUG: Code 3758097095 at mNR(~0Vx|!h0U~o5"F9V+HIE[~g.:29394896
DEBUG: Code 3758097095 at mNR(~0Vx|!h0U~o5"F9V+HIE[~g.:29394896
DEBUG: Code 3758097095 at mNR(~0Vx|!h0U~o5"F9V+HIE[~g.:29394896
Evaluation version, 27 day(s) out of 30 remaining
DEBUG: Code 0 at /Vu6AYr{}1T@`E.oG:121262164
DEBUG: Code 0 at /Vu6AYr{}1T@`E.oG:121262164
DEBUG: Code 0 at /Vu6AYr{}1T@`E.oG:121262164
DEBUG: Code 0 at /Vu6AYr{}1T@`E.oG:121262164
DEBUG: Code 8 at [3]uO]t{k8cYC)l6z?:121261980
Operation successfully completed
Saving 1 titles into directory /Users/Rich/Movies/MAKEMKV
DEBUG: Code 2147483647 at d7B3>Y]}#0^XS4`Ic2|:213129984
LIBMKV_TRACE: Exception: MKV_ASSERT: TimecodeDelay >= int16(0x8000) && TimecodeDelay <= int16(0x7FFF)
Failed to save title 1 to file /Users/Rich/Movies/MAKEMKV/t01_Feature_Presentation.mkv
0 titles saved, 1 failed

jmone
Posts: 18
Joined: Sat Jul 16, 2011 3:41 am

Re: Problematic HD-DVDs

Post by jmone » Sat Jul 16, 2011 3:56 am

Just started a trial and looking to convert all my HD-DVD. The first one I tried has issues:
1) Letters From Iwo Jima
2) WB / Dreamworks
3) VC-1 at 23.976fps
4) TrueHD, E-AC3
5) Video is reported and muxed as 29.97, not 23.976, Audio Tracks are reported and muxed as "Eng" mot "Jpn"
6) Debug log

Code: Select all

Debug log started at Sat Jul 16 03:53:12 2011 , written by MakeMKV v1.6.12 win(x64-release)
Using 524544KB for read cache.
001005:0000 MakeMKV v1.6.12 win(x64-release) started
001004:0000 Debug logging enabled, log will be saved as C:\Users\USERNAME/MakeMKV_log.txt
005050:0000 Evaluation version, 29 day(s) out of 30 remaining
001003:0020 DEBUG: Code 0 at <-5=mE]#F(yVukWWy:121262164
001003:0020 DEBUG: Code 0 at <-5=mE]#F(yVukWWy:121262164
003305:0000 AACS directory not present, assuming unencrypted disc
001003:0020 DEBUG: Code 233 at +Fw45nPrbWj7CpsEbO/fzIu3:0
005011:0000 Operation successfully completed
Application exited at Sat Jul 16 03:53:54 2011
EDIT: I tried the Transformers HD DVD and I also got the framerate being reported as 29.97 not 23.976

SamuriHL
Posts: 1052
Joined: Mon Jun 14, 2010 5:32 pm

Re: Problematic HD-DVDs

Post by SamuriHL » Sat Jul 16, 2011 4:55 am

VC-1 from HD DVD needs to have the pulldown flags removed. MakeMKV doesn't do that unfortunately. It was requested and rejected so you'll need to use another tool to remove the pulldown.

jmone
Posts: 18
Joined: Sat Jul 16, 2011 3:41 am

Re: Problematic HD-DVDs

Post by jmone » Sat Jul 16, 2011 5:09 am

SamuriHL wrote:VC-1 from HD DVD needs to have the pulldown flags removed. MakeMKV doesn't do that unfortunately. It was requested and rejected so you'll need to use another tool to remove the pulldown.
Thanks SamuriHL, got the same issue with the Transformers disc and it is an AVC...

EDIT: Checked with eac3to and this one is also reported with pulldown flags as - h264/AVC, 1080p24 /1.001 (16:9) with pulldown flags

SamuriHL
Posts: 1052
Joined: Mon Jun 14, 2010 5:32 pm

Re: Problematic HD-DVDs

Post by SamuriHL » Sat Jul 16, 2011 5:19 am

Delightful. That's always fun.

Post Reply