"Can't read AACS" from DVD

Everything related to MakeMKV
Post Reply
neil_
Posts: 1
Joined: Fri Apr 26, 2019 4:23 am

"Can't read AACS" from DVD

Post by neil_ » Fri Apr 26, 2019 4:57 am

I apologize in advance: I haven't been able to pin this down to a specific subsystem (hardware/software/disk) so I'm not sure if there's a better place to post this. I have seen these errors individually before and thought I understood the causes and fixes, but now I'm seeing them in a combination I don't understand and I've spent days trying unsuccessfully to figure out the problem.

SYMPTOMS AND OBSERVATIONS:
  • Trying to use `makemkvcon backup` with any DVD produces the error message "Can't read AACS VID from disc - most likely current AACS host certificate is revoked by your drive".
  • Using `vobcopy --mirror` had previously worked when `makemkvcon backup` failed, but now it also fails with pairs of "blk_update_request: I/O error" and "async page read" errors (which are only shown on the local console, not on the remote SSH session).
  • `makemkvcon info` seems to work perfectly (it dumps a bunch of information about the disk)
  • Behavior of `makemkvcon` does not seem affected by whether the disk is `mount`ed or not
ENVIRONMENT:
  • Ubuntu 16 (headless) in a VM
  • Drive: MBC001 (external BD-R; it's been working fine without external power but problems persist even with power added)
  • MakeMKV 1.14.3 (but I've been getting some of these same error messages since at least 1.14.2)
  • vobcopy 1.2.0
  • AACS: MKB_v31
DETAILS:
Up to now, I've been able to mirror about a half-dozen disks (almost all DVDs), but many of them I had to use `vobcopy` because of the same error messages below about AACS whenever I tried to use `makemkvcon backup` (at the time I saw forum postings from others saying that 1.14.2 had some issues so I concluded I was encountering the same issue, but now I'm not so sure).

Right now, when I put in any *DVD* (not Blu-Ray) and try to do `makemkvcon backup` I get what appears to be an error about AACS:

Code: Select all

$ makemkvcon backup disc:0 . --robot
MSG:1005,0,1,"MakeMKV v1.14.3 linux(x64-release) started","%1 started","MakeMKV v1.14.3 linux(x64-release)"
DRV:0,2,999,1,"BD-ROM NECVMWar VMware SATA CD00 1.00","BATB_ENCHANTED_CHRISTMAS","/dev/sr0"
DRV:1,0,999,0,"DVD-ROM NECVMWar VMware SATA CD01 1.00","","/dev/sr1"
DRV:2,256,999,0,"","",""
DRV:3,256,999,0,"","",""
DRV:4,256,999,0,"","",""
DRV:5,256,999,0,"","",""
DRV:6,256,999,0,"","",""
DRV:7,256,999,0,"","",""
DRV:8,256,999,0,"","",""
DRV:9,256,999,0,"","",""
DRV:10,256,999,0,"","",""
DRV:11,256,999,0,"","",""
DRV:12,256,999,0,"","",""
DRV:13,256,999,0,"","",""
DRV:14,256,999,0,"","",""
DRV:15,256,999,0,"","",""
MSG:5072,0,1,"Backing up disc into folder \".\"","Backing up disc into folder \"%1\"","."
MSG:3306,0,0,"Can't read AACS VID from disc - most likely current AACS host certificate is revoked by your drive","Can't read AACS VID from disc - most likely current AACS host certificate is revoked by your drive"
MSG:5069,128,0,"Backup failed","Backup failed"
MSG:5080,516,0,"Backup failed.","Backup failed."
Again: this happens no matter what DVD I put in.

When I try to use vobcopy (which was my previous solution), it runs for a bit and then stalls. But with vobcopy, on the console window I get this in a seemingly endless loop:

Code: Select all

Buffer I/O error on dev sr0, logical block 139310, async page read
blk_update_request: I/O error, dev sr0, sector 557244
Buffer I/O error on dev sr0, logical block 139311, async page read
blk_update_request: I/O error, dev sr0, sector 557240
(Sector numbers vary slightly but are similar for the same disk. Block numbers seem to vary for each disk.)

So now I'm stumped:
  • The AACS message may be a false-positive resulting from the `blk_update_request` errors, but I don't get those errors when using makekmvcon.
  • My search results tell me that the `blk_update_request` errors are supposed to be solved by installing libraries that I've already got (as I believe is demonstrated by the fact that `vobcopy --mirror` was working).
  • The drive currently does not have external power connected but if it needed that wouldn't `vobcopy` also A) Have been failing, and B) fail at random sectors?
I've tried going through the forums (and the broader web) for those various error messages, my drive model, and the FAQs (including the first ~3 pages of the "If you're experiencing rip errors, please read here first!" thread). I also read a little about LibreDrive but it doesn't "feel" like that would help with the problem I'm having (since it's DVD disks, not Blu-Ray).

If anyone could point me in the right direction, I would greatly appreciate it.


Thanks much,
-Neil

Woodstock
Posts: 6345
Joined: Sun Jul 24, 2011 11:21 pm

Re: "Can't read AACS" from DVD

Post by Woodstock » Fri Apr 26, 2019 12:50 pm

Backup only works for Bluray, so if you're telling MakeMKV to treat the DVD as a BD, of course it won't find the AACS...
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

Post Reply