Custom Profile will not load/ Audio selection

Discussion of advanced MakeMKV functionality, expert mode, conversion profiles
Post Reply
RocketFromTheTombs
Posts: 3
Joined: Thu Mar 14, 2019 2:42 pm

Custom Profile will not load/ Audio selection

Post by RocketFromTheTombs » Thu Mar 14, 2019 3:05 pm

Hi,
I have been trying to figure out how to get MakeMKV to rip ALL audio files, so that I can then select which ones I want to keep when I convert the files with HandBrake. I have a fair amount of foreign movies that I would like to keep the original language audio, as well as ALL English tracks, as I like to keep any commentary tracks included. When using the default profile, I can get an original language audio track, but usually only 1 English track.

I used the advice from this thread: viewtopic.php?t=8219
and modified the default profile with this line of code:

Code: Select all

    <profileSettings
        app_DefaultSelectionString="-sel:all,+sel:(favlang|nolang),-sel:mvcvideo,=100:all,-10:favlang"
    />
I renamed the profile to "Superaudio", and changed the name section of default profile as follows:

Code: Select all

<profile>
    <!-- profile name - Superaudio -->
    <name lang=“eng”>Superaudio</name>
I am running the CLI of version 1.12.3 linux(x64-release) on a server running Ubuntu 16.04.6. The new profile is saved in /usr/share/MakeMKV.

Whenever I try to rip with this command:

Code: Select all

makemkvcon mkv disc:0 all /media/rips --minlength=300 --profile=usr/share/MakeMKV/Superaudio.mmcp.xml
I get this message:

Code: Select all

Operation successfully completed
Failed to load profile from file 'usr/share/MakeMKV/Superaudio.mmcp.xml', using default
Saving 1 titles into directory /media/rips
I have been trying to figure this out for three days now, and it's driving me insane. Please help!
Thanks,
Brian

Woodstock
Posts: 6101
Joined: Sun Jul 24, 2011 11:21 pm

Re: Custom Profile will not load/ Audio selection

Post by Woodstock » Thu Mar 14, 2019 4:14 pm

Profile won't load: Check the syntax using an XML validator. I have one built in to the text editor I use (UltraEdit).

Auto select rules are now only set in the Advance tab of the GUI. I do not remember if it was 1.12 or 1.14 that introduced this change. If you have one in a profile, it will be ignored. Apparently people were confused over the hierarchy of which rule was being used, so Mike simplified things by only having one place that it is set.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

RocketFromTheTombs
Posts: 3
Joined: Thu Mar 14, 2019 2:42 pm

Re: Custom Profile will not load/ Audio selection

Post by RocketFromTheTombs » Thu Mar 14, 2019 9:42 pm

Thanks for the guidance Woodstock,
I did an XML syntax check, and found one error (no space after <name lang="eng"> before Superaudio<name>).
I corrected that error, and the new file passes the XML syntax check, but I still get the same "Failed to load profile" error.
Also, note that I am not using the GUI version; does this have anything to do with my problems?
Thanks again,
Brian

Woodstock
Posts: 6101
Joined: Sun Jul 24, 2011 11:21 pm

Re: Custom Profile will not load/ Audio selection

Post by Woodstock » Fri Mar 15, 2019 1:08 pm

If you're using the Linux version, the selection rule will be read from your configuration file (same file you put your license key in).

I haven't used the command line version of MakeMKV, so I do not know if it generates a debug log that might have more information on WHY the profile didn't load. One possibility (if the display in your previous messages is accurate) is that the double quote characters are wrong:

Code: Select all

<name lang=“eng”>Superaudio</name>
is not the same as:

Code: Select all

<name lang="eng">Superaudio</name>
And computers can be SO literal when interpreting things.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

RocketFromTheTombs
Posts: 3
Joined: Thu Mar 14, 2019 2:42 pm

Re: Custom Profile will not load/ Audio selection

Post by RocketFromTheTombs » Fri Mar 15, 2019 9:58 pm

Woodstock,
Thank you so much for your help!
I tried changing my double quote characters, and it didn't seem to make a difference...
So I started analyzing every character in my profile, and couldn't find anything.
Then I realized that I had a small typo in my file path. I feel like such a fool!
Anyway, thank you again for taking the time to assist.

-Brian

aan3kk
Posts: 3
Joined: Tue Mar 12, 2019 10:24 am

Re: Custom Profile will not load/ Audio selection

Post by aan3kk » Wed Apr 24, 2019 3:38 am

Woodstock wrote:
Thu Mar 14, 2019 4:14 pm
Auto select rules are now only set in the Advance tab of the GUI. I do not remember if it was 1.12 or 1.14 that introduced this change. If you have one in a profile, it will be ignored. Apparently people were confused over the hierarchy of which rule was being used, so Mike simplified things by only having one place that it is set.
One should have told them to disable Expert Mode then. It's basically very simple to figure out. Set the desired one in your profile and complete non-sense in the advanced tab. Export a Title and check the result. If it's the desired result profile takes precedence over advanced tab. If it's non-sense advanced tab takes precedence over profile.

Just because of some "I want Export Mode but don't have a damn clue what I'm doing" people the whole profile thingy turned completely useless for me. Maybe removing the setting in the advanced tab would have been better.

Post Reply