Version 1.42 says its expired

Old, outdated, resolved and locked topics end up here...

Moderator: mike admin

Post Reply
amirude
Posts: 1
Joined: Fri Mar 01, 2019 3:53 am

Version 1.42 says its expired

Post by amirude » Fri Mar 01, 2019 4:00 am

Tried installing the newest version 1.42 systems says its out of date.

Any ideas?


Post Reply