Dolby Vision and 1.15.3

Please post here for issues related to UHD discs
siriusbox
Posts: 31
Joined: Thu Mar 12, 2020 3:07 pm

Re: Dolby Vision and 1.15.3

Post by siriusbox » Sun Oct 11, 2020 11:35 am

Hi, I have lot of MKVs that I made in the past with MKVToolnix keeping Dolby Vision layer as a second track (in the hope it could be handled some day), I've tried with the latest version of MakeMKV but it doesn't recognize it, any ideas?

shawnc22
Posts: 500
Joined: Tue Jan 21, 2020 7:40 am

Re: Dolby Vision and 1.15.3

Post by shawnc22 » Sun Oct 11, 2020 7:13 pm

siriusbox wrote:
Sun Oct 11, 2020 11:35 am
Hi, I have lot of MKVs that I made in the past with MKVToolnix keeping Dolby Vision layer as a second track (in the hope it could be handled some day), I've tried with the latest version of MakeMKV but it doesn't recognize it, any ideas?
viewtopic.php?f=12&t=23306&start=90#p97479

Same situation, but it's seemingly ymmv as a few others have reported since then with the tsmuxer method.

siriusbox
Posts: 31
Joined: Thu Mar 12, 2020 3:07 pm

Re: Dolby Vision and 1.15.3

Post by siriusbox » Sun Oct 11, 2020 7:59 pm

I've tried creating BR structure with tsmuxer 2.6.12 but when I try to open with MakeMKV it says Failed to open disc.

Low Winter Sun
Posts: 32
Joined: Thu Dec 28, 2017 11:51 pm

Re: Dolby Vision and 1.15.3

Post by Low Winter Sun » Sun Oct 11, 2020 8:02 pm

Re-rip them all with the latest version of Makemkv. Having the Dolby Vision layer as a second separate video track in an MKV file has never been part of the MKV standard.
siriusbox wrote:
Sun Oct 11, 2020 11:35 am
Hi, I have lot of MKVs that I made in the past with MKVToolnix keeping Dolby Vision layer as a second track (in the hope it could be handled some day), I've tried with the latest version of MakeMKV but it doesn't recognize it, any ideas?

phneutral
Posts: 13
Joined: Wed Oct 07, 2020 6:57 am

Re: Dolby Vision and 1.15.3

Post by phneutral » Mon Oct 12, 2020 5:49 am

Fuluer wrote:
Mon Oct 05, 2020 3:53 am
Fuluer wrote:
Sat Oct 03, 2020 7:39 pm
Using an old version of MakeMKV, I used to backup my disks, and then use MKVtoolnix to create an MKV with both video streams embedded. The videos have always played fine, though without DV.

I now have Shield/Kodi/Exoplayer setup, and can play the newer MKVs from 1.15.2+

But when I try and open one of my older MKV's with MakeMKV 1.15.3, only the BL is detected.

What would be the correct workflow to convert the older MKVs to the new format without lossy transcoding?
So after a bit of experimentation, I confirmed that if I use tsmuxer-4.06 to create a blu-ray.iso using just the video tracks, Makemkv 1.15.3 will convert that iso to a proper DV MKV. Then I add that mkv and the original mkv to mkvtoolnix, and get a working DV MKV with atmos, PGS subs, chapters, etc.

Couple questions -
1) Is tsmuxer-4.06 necessary, or should I use another version to maintain maximum information? I know there are several versions of tsmuxer for DV, but I'm not savvy to the differences. Should I just use the latest nightly?
2) tsmuxer takes a long time and doesn't support queuing. Is there a way to get the same result faster using another workflow?
Anyone got a link to tsmuxer-4.06? Looked everywhere can only find latest build.

siriusbox
Posts: 31
Joined: Thu Mar 12, 2020 3:07 pm

Re: Dolby Vision and 1.15.3

Post by siriusbox » Mon Oct 12, 2020 8:24 am

siriusbox wrote:
Sun Oct 11, 2020 7:59 pm
I've tried creating BR structure with tsmuxer 2.6.12 but when I try to open with MakeMKV it says Failed to open disc.
Looks like it was a problem with TSMuxer version, I'm using nightly build now and the bluray structure created is now recognized by MakeMKV.

phneutral
Posts: 13
Joined: Wed Oct 07, 2020 6:57 am

Re: Dolby Vision and 1.15.3

Post by phneutral » Mon Oct 12, 2020 10:38 am

siriusbox wrote:
Mon Oct 12, 2020 8:24 am
siriusbox wrote:
Sun Oct 11, 2020 7:59 pm
I've tried creating BR structure with tsmuxer 2.6.12 but when I try to open with MakeMKV it says Failed to open disc.
Looks like it was a problem with TSMuxer version, I'm using nightly build now and the bluray structure created is now recognized by MakeMKV.
That's a result, thanks for the tip

phneutral
Posts: 13
Joined: Wed Oct 07, 2020 6:57 am

Re: Dolby Vision and 1.15.3

Post by phneutral » Mon Oct 12, 2020 1:38 pm

Lush78 wrote:
Sun Oct 11, 2020 11:16 am
phneutral wrote:
Sun Oct 11, 2020 8:53 am
shawnc22 wrote:
Thu Oct 08, 2020 7:07 pm

Right, and the couple posts right after that showed that it doesn't really work if you start with an mkv that contains the original BL and EL layers in separate tracks. I'm not sure if it's supposed to or if it's just a bug, but it doesn't seem to be the case at the moment. Although, if the method listed in mike's OP works for DV mp4's that likely also has the BL and EL layers in separate tracks, then it should theoretically work for an mkv that has the same structure as well. So maybe try the exact steps outlined in the first post and see how it turns out? The method to create these mkvs in the first place is a bit unorthodox (assuming decrypted folder backup -> mkvtoolsnix to manually select both video tracks), so could be just a ymmv kind of situation.
Alright, I see others are having success with separate tracks by using tsmuxer to create a new iso - so I tried this but unfortunately MakeMKV won't open it, same if I create a blu-ray folder instead, i'm getting this error:

Code: Select all

DEBUG: Code 2 at V_xQ^nN8a$*i g:29405085
DEBUG: Code 0 at V_xQ^nN8a$*i g:29403912
DEBUG: Code 0 at 8p484H Too-'r[U*:121267983
AACS directory not present, assuming unencrypted disc
DEBUG: Code 0 at M!5Nsiq7W[8F|Ha,:121262302
DEBUG: Code 0 at u:_`KHcAwIMr}dO:29401934
DEBUG: Code 0 at 8p484H Too-'r[U*:213116437
Title #00000.m2ts was skipped
Failed to open disc
Are these rips corrupted or am I missing a setting?
I was able to get it working by creating BluRay iso using txmuxer, but I was getting a ton of AV sync issues in makemkv when creating mkv from said iso.
I'm seeing the same, guessing that's because we stripped out the audio in tsmuxer when making the ISO? I'm adding the audio back in now with MKVToolnix

Digital moe
Posts: 37
Joined: Thu Aug 30, 2018 12:03 pm

Re: Dolby Vision and 1.15.3

Post by Digital moe » Mon Oct 12, 2020 6:19 pm

siriusbox wrote:
Sun Oct 11, 2020 11:35 am
Hi, I have lot of MKVs that I made in the past with MKVToolnix keeping Dolby Vision layer as a second track (in the hope it could be handled some day), I've tried with the latest version of MakeMKV but it doesn't recognize it, any ideas?
You should just be able to open that .mkv in 1.15.3 let MakeMKV do its thing and you will have a fully functional DV .mkv.

shawnc22
Posts: 500
Joined: Tue Jan 21, 2020 7:40 am

Re: Dolby Vision and 1.15.3

Post by shawnc22 » Mon Oct 12, 2020 6:29 pm

Digital moe wrote:
Mon Oct 12, 2020 6:19 pm
siriusbox wrote:
Sun Oct 11, 2020 11:35 am
Hi, I have lot of MKVs that I made in the past with MKVToolnix keeping Dolby Vision layer as a second track (in the hope it could be handled some day), I've tried with the latest version of MakeMKV but it doesn't recognize it, any ideas?
You should just be able to open that .mkv in 1.15.3 let MakeMKV do its thing and you will have a fully functional DV .mkv.
No, not sure if it's intended, but if the input mkv has the DV layer on a second video track, then 1.15.3 will not currently recognize it as DV.

phneutral
Posts: 13
Joined: Wed Oct 07, 2020 6:57 am

Re: Dolby Vision and 1.15.3

Post by phneutral » Mon Oct 12, 2020 8:47 pm

shawnc22 wrote:
Mon Oct 12, 2020 6:29 pm
Digital moe wrote:
Mon Oct 12, 2020 6:19 pm
siriusbox wrote:
Sun Oct 11, 2020 11:35 am
Hi, I have lot of MKVs that I made in the past with MKVToolnix keeping Dolby Vision layer as a second track (in the hope it could be handled some day), I've tried with the latest version of MakeMKV but it doesn't recognize it, any ideas?
You should just be able to open that .mkv in 1.15.3 let MakeMKV do its thing and you will have a fully functional DV .mkv.
No, not sure if it's intended, but if the input mkv has the DV layer on a second video track, then 1.15.3 will not currently recognize it as DV.
Correct. I've now successfully created a DV MKV from an old rip which plays with TrueHD Atmos in Plex 8.8.0.21074-beta on the Shield, using the workaround with tsmuxer nightly build (video layers only) > iso > makemkv 1.15.3 > mkvtoolnix (adding back audio)

Thanks all!

cuculain
Posts: 11
Joined: Fri Oct 09, 2020 6:28 am

Re: Dolby Vision and 1.15.3

Post by cuculain » Tue Oct 13, 2020 8:17 pm

Dunno if this helps at all
Zidoo Z9X .35 firmware sony dn1080 amp Panasonic z1000 OLED

It seems to be just the audio type,thats causing issues for the playback of makemkv conversions
ie
ma 5.1 DV MEL 7.06 movies ,Pitch Black and Flash gordon ,played back fine no stutters in the 20 mins plus i played both
MA 5.1 DV MEL 7.06 movie Casino Royale was almost perfect ,with just a few micro stutters during the movie and Dobly vison flash up with a slight pause a couple times
Atmos DV MEL 7.06 movies Alita and Justice League start fine but within 4-5 mins theres stutters and audio starts falling behind

hope the info helps some and colours in Flash gordon are awesome ..the red of the lycra bodysuit is so RED :)

all triggered dolby vision at start
ill rip a couple more of the Bond movies to confirm the 5,1 MA minor stutters etc today with luck

G4n0nD0rf
Posts: 2
Joined: Fri Oct 09, 2020 8:44 am

Re: Dolby Vision and 1.15.3

Post by G4n0nD0rf » Wed Oct 14, 2020 1:32 pm

G4n0nD0rf wrote:
Fri Oct 09, 2020 8:55 am
When remuxing an mkv with a DV FEL as a secondary video track, the resulting file is several GB smaller than the original. The difference in size is roughly the same as the size of the original second video track according to MediaInfo. How is this possible? Where has the FEL data gone? MakeMKV recognizes both the input as the output file as dvhe.07.06 BL+FEL+RPU.
Am I the only one who wonders where the FEL data has gone to? It seems that only the metadata is preserved but not the full enhancement layer.

mike admin
Posts: 3889
Joined: Wed Nov 26, 2008 2:26 am
Contact:

Re: Dolby Vision and 1.15.3

Post by mike admin » Fri Oct 16, 2020 2:44 pm

jlpsvk wrote:
Fri Oct 09, 2020 11:19 pm
1) accept raw HEVC stream as input to create DV MKV
Just convert it to mkv with mkvtoolnix (or ffmpeg), then open a produced "crappy mkv" as usual.

Decidueye
Posts: 9
Joined: Sun Sep 27, 2020 9:47 am

Re: Dolby Vision and 1.15.3

Post by Decidueye » Sat Oct 17, 2020 4:53 am

Hello everyone, newbie here.

When I play the new DV MKVs by 1.15.3 with the Shield, there's inconsistency. Sometimes it is direct playing DV and lossless Atmos / DTS:X fine, sometimes it is transcoding. And it gets worse -- when I play a DV file then switch to an HDR one then back to a DV file, it will more often transcode.

What I tried:
1.) Changing refresh rate on Shield settings - tried 59.94hz, 29.97hz, 60hz - all have problems
2.) Set Shield performance to Max - no effect
3.) Exit the playback and replay the movie - sometimes it works, sometimes does not and restarting and Shield is the only fix, but then after switching files, problem comes up again

On other non-DV MKVs, the Shield plays it just fine.

My setup:
Shield > Plex Beta 8.8.0.21074 > LG C9 (ULTRA HD DEEP COLOR ON, Passthrough, Bitstream) > eARC > Samsung HW-Q90R soundbar

Is this normal? I tried different 2.1 HDMI cables but the problem remains. Tried on different servers (NAS and Desktop PC). What might be the problem in my case?

Post Reply