My head hurts from this...

Forum for discussions about UHD-capable dives
Post Reply
VegasMan
Posts: 5
Joined: Tue Oct 08, 2019 9:47 pm

My head hurts from this...

Post by VegasMan » Tue Oct 08, 2019 9:54 pm

Been trying to wrap my head around the whole firmware downgrade or upgrade and how to exactly do it.
I read several threads, downloaded flashers and tried several firmware files...
no luck. Just errors...

There has to be a more noob guide on this or maybe I am missing something.

This is the drive I bought:
https://www.amazon.com/gp/product/B07BC ... UTF8&psc=1

The box says "MD-8107S-U3YC-UHD"

According to MakeMKV:
Manufacturer: HL-DT-ST
Product: BD-RE BU40N
Revision: 1.01
Firmware date: 2117-12-22 12:21

From what I understand these are LG drives really... just rebranded.

Anywho.... like I stated earlier, tried several flashers and firmwares.

Checksum errors, etc...

Any guidance would be sooooo appreciated at this point.

MartyMcNuts
Posts: 498
Joined: Wed Nov 22, 2017 11:45 pm

Re: My head hurts from this...

Post by MartyMcNuts » Wed Oct 09, 2019 1:58 am

VegasMan wrote:
Tue Oct 08, 2019 9:54 pm
Been trying to wrap my head around the whole firmware downgrade or upgrade and how to exactly do it.
I read several threads, downloaded flashers and tried several firmware files...
no luck. Just errors...

There has to be a more noob guide on this or maybe I am missing something.

This is the drive I bought:
https://www.amazon.com/gp/product/B07BC ... UTF8&psc=1

The box says "MD-8107S-U3YC-UHD"

According to MakeMKV:
Manufacturer: HL-DT-ST
Product: BD-RE BU40N
Revision: 1.01
Firmware date: 2117-12-22 12:21

From what I understand these are LG drives really... just rebranded.

Anywho.... like I stated earlier, tried several flashers and firmwares.

Checksum errors, etc...

Any guidance would be sooooo appreciated at this point.
Use the search function at the top of the page and search for "Archgon". You will find the info you require.

If you are really lazy and don't want to search for the info, use the ASUS flasher and flash BU40N 1.00 to your drive.

st4evr
Posts: 486
Joined: Tue Mar 06, 2018 11:38 pm

Re: My head hurts from this...

Post by st4evr » Wed Oct 09, 2019 4:01 am

Or, pay someone to do it for you:

https://www.makemkv.com/forum/viewforum.php?f=20

VegasMan
Posts: 5
Joined: Tue Oct 08, 2019 9:47 pm

Re: My head hurts from this...

Post by VegasMan » Wed Oct 09, 2019 5:59 am


Use the search function at the top of the page and search for "Archgon". You will find the info you require.

If you are really lazy and don't want to search for the info, use the ASUS flasher and flash BU40N 1.00 to your drive.
I tried that.... both things... several hours later...
Wasn't lazy.

Did several searches and read several threads... tried several firmwares and flashers...


That firmware didn't load. Checksum error, etc...

MartyMcNuts
Posts: 498
Joined: Wed Nov 22, 2017 11:45 pm

Re: My head hurts from this...

Post by MartyMcNuts » Thu Oct 10, 2019 1:36 am

VegasMan wrote:
Wed Oct 09, 2019 5:59 am

Use the search function at the top of the page and search for "Archgon". You will find the info you require.

If you are really lazy and don't want to search for the info, use the ASUS flasher and flash BU40N 1.00 to your drive.
I tried that.... both things... several hours later...
Wasn't lazy.

Did several searches and read several threads... tried several firmwares and flashers...


That firmware didn't load. Checksum error, etc...
Not sure why it didn’t work for you but everyone I have helped with the Archgon (Bu40n) has flashed Bu40n 1.00 firmware without issue using the modified asus flasher.

Make sure that nothing is running in the background, such as anyDVD, dvdfab etc... Also, are you an administrator on your computer?

BlueMac77
Posts: 77
Joined: Fri Jul 13, 2018 10:49 pm
Contact:

Re: My head hurts from this...

Post by BlueMac77 » Thu Oct 10, 2019 7:28 pm

VegasMan wrote:
Wed Oct 09, 2019 5:59 am

I tried that.... both things... several hours later...
Wasn't lazy.

Did several searches and read several threads... tried several firmwares and flashers...


That firmware didn't load. Checksum error, etc...
Maybe you can provide more details on how you're applying the firmware to the drive or screenshots of the error messages so the experts here may be able to help. And some info on how the external slim drive is connected to your computer.

VegasMan
Posts: 5
Joined: Tue Oct 08, 2019 9:47 pm

Re: My head hurts from this...

Post by VegasMan » Fri Oct 11, 2019 7:12 pm

Details as best I can:

The external drive info
Manufacturer: HL-DT-ST
Product: BD-RE BU40N
Revision: 1.01
Firmware date: 2117-12-22 12:21

Connected via USB 3.0 on computer
Windows 10 (All updated and video card drivers updated)

I uninstalled all of the AnyDVD products because of this may be a conflict.

Only thing installed is MakeMKV.

The following links were provided on the forum for a basic guide to update the firmware.

Attempting to flash firmware using "BH14NS40_N1.00-A4_patched.exe" found on this link:
https://www.makemkv.com/forum/viewtopic ... 873#p70284

using the following firmware file "DE_LG BU40N_1.00.bin"

I get the following error no matter which firmware I try to use.

CheckSum is mismatched.
Drive will go to BOOT Mode
Please retry again


I tried other links but it was the FW changer which didn't even work at all, kept saying DeviceIoControl error: Error Code 121
That was the "ASUS_ODD_FW_Changer_(Modified).exe" file.



Please let me know if there is any additional information that could help anyone guide me through this process.

VegasMan
Posts: 5
Joined: Tue Oct 08, 2019 9:47 pm

Re: My head hurts from this...

Post by VegasMan » Mon Oct 14, 2019 6:09 pm

No one?

:roll:

Coopervid
Posts: 28
Joined: Tue Feb 19, 2019 10:32 pm

Re: My head hurts from this...

Post by Coopervid » Mon Oct 14, 2019 6:48 pm

The Issue is most likely the connection via USB. Not all interfaces support all necessary commands to flash your drive. You should connect it directly to your computer via SATA if you have the possibility. Then you can put it back to the USB connection.

VegasMan
Posts: 5
Joined: Tue Oct 08, 2019 9:47 pm

Re: My head hurts from this...

Post by VegasMan » Wed Oct 16, 2019 7:49 pm

This is the first I am hearing of this potential problem.
Even with my original post I give a link to the product being an external.
I didn't see anything about this being a problem with the instructions on flashing drives.

I guess I will do my best to take apart this external case and try to connect it via sata.

Post Reply