BU40N - Which firmware is best?

Forum for discussions about UHD-capable dives
ionblue
Posts: 6
Joined: Wed Jan 06, 2016 7:27 pm

BU40N - Which firmware is best?

Post by ionblue » Tue Jul 02, 2019 8:18 pm

Hi there. I purchased an Archgon-8107S so I could rip UHD's and I've successfully downgraded it in a Windows VM to version 1.00. I saw a few other firmwares in the zip file, but wasn't sure which was best. Is 1.00 OK or should I use one of the other ones? I am able to read UHD now so at least that's working!

MartyMcNuts
Posts: 457
Joined: Wed Nov 22, 2017 11:45 pm

Re: BU40N - Which firmware is best?

Post by MartyMcNuts » Wed Jul 03, 2019 12:50 am

ionblue wrote:
Tue Jul 02, 2019 8:18 pm
Hi there. I purchased an Archgon-8107S so I could rip UHD's and I've successfully downgraded it in a Windows VM to version 1.00. I saw a few other firmwares in the zip file, but wasn't sure which was best. Is 1.00 OK or should I use one of the other ones? I am able to read UHD now so at least that's working!
Stick with 1.00. It works really well!

ionblue
Posts: 6
Joined: Wed Jan 06, 2016 7:27 pm

Re: BU40N - Which firmware is best?

Post by ionblue » Wed Jul 03, 2019 12:57 am

You’re right about that. This is the fastest drive I currently have! Thank you and thanks to all that make this possible!

m-p-h
Posts: 7
Joined: Fri Jun 14, 2019 8:55 pm

Re: BU40N - Which firmware is best?

Post by m-p-h » Wed Jul 03, 2019 11:13 am

Which one did you use?

BU40N-N
BU40N-R
BU40N-U

ionblue
Posts: 6
Joined: Wed Jan 06, 2016 7:27 pm

Re: BU40N - Which firmware is best?

Post by ionblue » Wed Jul 03, 2019 3:23 pm

m-p-h wrote:
Wed Jul 03, 2019 11:13 am
Which one did you use?

BU40N-N
BU40N-R
BU40N-U
Just the straight BU40N 1.00 one (DE_LG BU40N_1.00.bin). I wasn't sure if I should use any of those in particular. Should I have?

m-p-h
Posts: 7
Joined: Fri Jun 14, 2019 8:55 pm

Re: BU40N - Which firmware is best?

Post by m-p-h » Wed Jul 03, 2019 10:10 pm

I don't know... hence why I was asking :-)

I only know the DE is "Downgrade Enable" and the other 3 are MK images, but not sure of the exact differences.

ionblue
Posts: 6
Joined: Wed Jan 06, 2016 7:27 pm

Re: BU40N - Which firmware is best?

Post by ionblue » Wed Jul 03, 2019 10:41 pm

m-p-h wrote:
Wed Jul 03, 2019 10:10 pm
I don't know... hence why I was asking :-)

I only know the DE is "Downgrade Enable" and the other 3 are MK images, but not sure of the exact differences.
Well, everything is working now so I’m happy. If anyone knows what the other versions do and if I should use one, please let me know. I know I saw the N version mentioned in another thread, but again, I wasn’t sure about which one.

d00zah
Posts: 510
Joined: Mon Jun 06, 2016 8:23 pm

Re: BU40N - Which firmware is best?

Post by d00zah » Wed Jul 03, 2019 11:31 pm

ionblue wrote:
Wed Jul 03, 2019 10:41 pm
Well, everything is working now so I’m happy. If anyone knows what the other versions do and if I should use one, please let me know. I know I saw the N version mentioned in another thread, but again, I wasn’t sure about which one.
From the original thread announcing the MK FWs... "there are three different BU40 models - Taiwan, USA and Europe. If unsure, do not flash, and wait for LibreDrive flasher app to be released." As to which is which, I recall it being discussed in a different thread. Feel free to search if you just gotta know. :)

m-p-h
Posts: 7
Joined: Fri Jun 14, 2019 8:55 pm

Re: BU40N - Which firmware is best?

Post by m-p-h » Thu Jul 04, 2019 7:40 pm

Yeah found that info :-)
I used the MK image with the same SDF number as the one on my drive: R.
The flasher app never actually finished and hung at around 90%. The drive wouldn't recognise any discs, so I thought I'd bricked it :x
Disconnected and reconnected and all ok, with the new FW on it :D

d22901
Posts: 12
Joined: Mon Jul 15, 2019 10:53 pm

Re: BU40N - Which firmware is best?

Post by d22901 » Mon Jul 15, 2019 11:02 pm

MartyMcNuts wrote:
Wed Jul 03, 2019 12:50 am
Stick with 1.00. It works really well!
Just started using this external UHD drive - I can get through UHD discs just fine; however, I have noticed that there are spin down pauses at times during the process where the drive seems to go dormant, only to start back up seemingly at random. As noted, the process seems to never actually fail, but I'm not seeing consistent throughput from start to finish with firmware version 1.00. Read speeds reach 6.0X when the drive is active, so when the drive is running, it's running well. Is there something obvious I'm missing here? The only qualifier to note here is that I'm ripping direct to my QNAP TS-453 Pro NAS on my network. With that said, I was using a Pioneer BDR-XD05S to take care of standard blu-ray discs prior to acquiring this Archgon external - throughput was a consistent (albeit meager) 2.0X with no dormant stretches in read.

MartyMcNuts
Posts: 457
Joined: Wed Nov 22, 2017 11:45 pm

Re: BU40N - Which firmware is best?

Post by MartyMcNuts » Tue Jul 16, 2019 5:15 am

d22901 wrote:
Mon Jul 15, 2019 11:02 pm
MartyMcNuts wrote:
Wed Jul 03, 2019 12:50 am
Stick with 1.00. It works really well!
Just started using this external UHD drive - I can get through UHD discs just fine; however, I have noticed that there are spin down pauses at times during the process where the drive seems to go dormant, only to start back up seemingly at random. As noted, the process seems to never actually fail, but I'm not seeing consistent throughput from start to finish with firmware version 1.00. Read speeds reach 6.0X when the drive is active, so when the drive is running, it's running well. Is there something obvious I'm missing here? The only qualifier to note here is that I'm ripping direct to my QNAP TS-453 Pro NAS on my network. With that said, I was using a Pioneer BDR-XD05S to take care of standard blu-ray discs prior to acquiring this Archgon external - throughput was a consistent (albeit meager) 2.0X with no dormant stretches in read.
They usually slow right down on layer changes.

d22901
Posts: 12
Joined: Mon Jul 15, 2019 10:53 pm

Re: BU40N - Which firmware is best?

Post by d22901 » Tue Jul 16, 2019 12:01 pm

MartyMcNuts wrote:
Tue Jul 16, 2019 5:15 am
d22901 wrote:
Mon Jul 15, 2019 11:02 pm
MartyMcNuts wrote:
Wed Jul 03, 2019 12:50 am
Stick with 1.00. It works really well!
Just started using this external UHD drive - I can get through UHD discs just fine; however, I have noticed that there are spin down pauses at times during the process where the drive seems to go dormant, only to start back up seemingly at random. As noted, the process seems to never actually fail, but I'm not seeing consistent throughput from start to finish with firmware version 1.00. Read speeds reach 6.0X when the drive is active, so when the drive is running, it's running well. Is there something obvious I'm missing here? The only qualifier to note here is that I'm ripping direct to my QNAP TS-453 Pro NAS on my network. With that said, I was using a Pioneer BDR-XD05S to take care of standard blu-ray discs prior to acquiring this Archgon external - throughput was a consistent (albeit meager) 2.0X with no dormant stretches in read.
They usually slow right down on layer changes.
Thanks for the follow-up. Will consider this behavior normal in that case. My Pioneer drive not exhibiting this behavior made me pause.

d22901
Posts: 12
Joined: Mon Jul 15, 2019 10:53 pm

Re: BU40N - Which firmware is best?

Post by d22901 » Wed Jul 17, 2019 8:59 pm

I should have qualified my original post by indicating that these spin-downs can last several minutes prior to resuming the rip.

MartyMcNuts
Posts: 457
Joined: Wed Nov 22, 2017 11:45 pm

Re: BU40N - Which firmware is best?

Post by MartyMcNuts » Thu Jul 18, 2019 12:54 am

d22901 wrote:
Wed Jul 17, 2019 8:59 pm
I should have qualified my original post by indicating that these spin-downs can last several minutes prior to resuming the rip.
That's ok. It happens but they eventually pick up speed again.

d22901
Posts: 12
Joined: Mon Jul 15, 2019 10:53 pm

Re: BU40N - Which firmware is best?

Post by d22901 » Thu Jul 18, 2019 1:10 am

MartyMcNuts wrote:
Thu Jul 18, 2019 12:54 am
d22901 wrote:
Wed Jul 17, 2019 8:59 pm
I should have qualified my original post by indicating that these spin-downs can last several minutes prior to resuming the rip.
That's ok. It happens but they eventually pick up speed again.
Indeed - the drive always seems to resume on 1.00 (eventually). Just seems to randomly stall many times during each rip. For instance, I'm at 2 hours and 38 minutes on a 4k rip of Avengers-Age of Ultron with still a little more time to complete. But when the drive is actually active, at 6.0X, this ~55 GB rip would be done in around 45 minutes or so (maybe even less) if it consistently read the entire time. I wonder if the MK version of 1.03 would modify this behavior in any way?

Post Reply