BU40N 1.03 to MK 1.03 - Not sure where to go from here

Forum for discussions about UHD-capable dives
Post Reply
feralgoose
Posts: 8
Joined: Wed Jul 10, 2019 11:10 pm

BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by feralgoose » Wed Jul 10, 2019 11:56 pm

Hi, total newb here. I've been reading lots of posts in this forum and I still can't figure out how to get LibreDrive enabled for my drive. I have the modified ASUS ODD FW Changer and I believe I am supposed to "sidegrade" to Asus 3.10MK before I can flash MK 1.03. As far as I can figure out, "Asus 3.10MK" is under mk-firmware-pack-20190319\MK\ASUS\BW-16D1HT. (I opened every directory in the firmware pack to come up with that guess). When I try to flash it, I get "Updating Failure #4". I am sure I am missing some critical and obvious step so any help would be greatly appreciated. From the log file, my drive is HL-DT-ST_BD-RE_BU40N_1.03_211810241934_XXXXXXXXXXX

MartyMcNuts
Posts: 452
Joined: Wed Nov 22, 2017 11:45 pm

Re: BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by MartyMcNuts » Thu Jul 11, 2019 4:54 am

feralgoose wrote:
Wed Jul 10, 2019 11:56 pm
Hi, total newb here. I've been reading lots of posts in this forum and I still can't figure out how to get LibreDrive enabled for my drive. I have the modified ASUS ODD FW Changer and I believe I am supposed to "sidegrade" to Asus 3.10MK before I can flash MK 1.03. As far as I can figure out, "Asus 3.10MK" is under mk-firmware-pack-20190319\MK\ASUS\BW-16D1HT. (I opened every directory in the firmware pack to come up with that guess). When I try to flash it, I get "Updating Failure #4". I am sure I am missing some critical and obvious step so any help would be greatly appreciated. From the log file, my drive is HL-DT-ST_BD-RE_BU40N_1.03_211810241934_XXXXXXXXXXX
I believe that side-grading to ASUS 3.10-MK is only for desktop drives, not the BU40N.

Have you tried flashing from 1.03 to 1.00 directly? If that didn't work, then try flashing from 1.03 to 1.02-MK or 1.03-MK. If successful, you can then flash to 1.00.

Billycar11
Posts: 476
Joined: Sun Aug 24, 2014 5:49 am

Re: BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by Billycar11 » Thu Jul 11, 2019 8:18 am

definitely do not flash asus 3.10mk you will be unable to go back to bu40n fw without the new dos flash windows flashers won't work, i have done it to prove amscom WRONG before 1.03mk was out and well he is WRONG but see if i release this info publicly people will misread/understand it again and ruin their dive.
if anyone softbricks there drive this way pm me if and only if your pc supports dosflash i'll help you

feralgoose
Posts: 8
Joined: Wed Jul 10, 2019 11:10 pm

Re: BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by feralgoose » Thu Jul 11, 2019 11:03 am

MartyMcNuts wrote:
Thu Jul 11, 2019 4:54 am
feralgoose wrote:
Wed Jul 10, 2019 11:56 pm
Hi, total newb here. I've been reading lots of posts in this forum and I still can't figure out how to get LibreDrive enabled for my drive. I have the modified ASUS ODD FW Changer and I believe I am supposed to "sidegrade" to Asus 3.10MK before I can flash MK 1.03. As far as I can figure out, "Asus 3.10MK" is under mk-firmware-pack-20190319\MK\ASUS\BW-16D1HT. (I opened every directory in the firmware pack to come up with that guess). When I try to flash it, I get "Updating Failure #4". I am sure I am missing some critical and obvious step so any help would be greatly appreciated. From the log file, my drive is HL-DT-ST_BD-RE_BU40N_1.03_211810241934_XXXXXXXXXXX
I believe that side-grading to ASUS 3.10-MK is only for desktop drives, not the BU40N.

Have you tried flashing from 1.03 to 1.00 directly? If that didn't work, then try flashing from 1.03 to 1.02-MK or 1.03-MK. If successful, you can then flash to 1.00.
I believe I have tried most of what you suggested already but to be fair I think I'm ignorant enough to mistake one file from the next. Would you mind telling me where those files can be found? I believe I have the latest pack of firmwares from here but maybe I am looking in the wrong place. I am willing to try each of your suggestions in order if I can.

feralgoose
Posts: 8
Joined: Wed Jul 10, 2019 11:10 pm

Re: BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by feralgoose » Thu Jul 11, 2019 11:10 am

Billycar11 wrote:
Thu Jul 11, 2019 8:18 am
definitely do not flash asus 3.10mk you will be unable to go back to bu40n fw without the new dos flash windows flashers won't work, i have done it to prove amscom WRONG before 1.03mk was out and well he is WRONG but see if i release this info publicly people will misread/understand it again and ruin their dive.
if anyone softbricks there drive this way pm me if and only if your pc supports dosflash i'll help you
I don't think I have softbricked it but maybe I have. It seems like no matter which firmware I try to flash I get "Updating Failure #4". But I am not convinced I have tried the correct way to downgrade this drive, if one exists.

feralgoose
Posts: 8
Joined: Wed Jul 10, 2019 11:10 pm

Re: BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by feralgoose » Thu Jul 11, 2019 11:38 am

I have also tried the "Ultra Hax0R" Guide using the included file DE_LG BU40N_1.00.bin and I get "Write DRAM NG 05/26/02".

Billycar11
Posts: 476
Joined: Sun Aug 24, 2014 5:49 am

Re: BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by Billycar11 » Thu Jul 11, 2019 4:44 pm

I see why no one can find mk1.03 for BU40N it's missing from the mk firmware pack here is 1.03mk https://www.makemkv.com/forum/viewtopic ... 19&t=19422
I told Mike it's missing so it should be added to the pack soon

feralgoose
Posts: 8
Joined: Wed Jul 10, 2019 11:10 pm

Re: BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by feralgoose » Thu Jul 11, 2019 5:12 pm

Billycar11 wrote:
Thu Jul 11, 2019 4:44 pm
I see why no one can find mk1.03 for BU40N it's missing from the mk firmware pack here is 1.03mk https://www.makemkv.com/forum/viewtopic ... 19&t=19422
I told Mike it's missing so it should be added to the pack soon
Thanks for pointing me to the right .bin. I tried it with the Ultra Hax0R HLDS program and it gave me the "Write DRAM NG 05/24/00" error. I also tried it with the modified ASUS program and it says "Updating Failure #4". Could this be bad hardware or am I still missing something? I have the drive in a Vantec USB 3.0 Slim SATA Optical Drive Enclosure (NST-510S3-BK).

feralgoose
Posts: 8
Joined: Wed Jul 10, 2019 11:10 pm

Re: BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by feralgoose » Thu Jul 11, 2019 5:45 pm

Just to add, as far as I can tell, the drive is still reading disks.

Billycar11
Posts: 476
Joined: Sun Aug 24, 2014 5:49 am

Re: BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by Billycar11 » Thu Jul 11, 2019 6:35 pm

feralgoose wrote:
Thu Jul 11, 2019 5:45 pm
Just to add, as far as I can tell, the drive is still reading disks.
Me and puddingistastyapples are the same person on YouTube here is the better place to post

It's good that it still reads disks. The next thing to try is on a different PC and if they does not work then direct sata connection and if you can't do that you can always send it to me or buy one from me.

feralgoose
Posts: 8
Joined: Wed Jul 10, 2019 11:10 pm

Re: BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by feralgoose » Thu Jul 11, 2019 10:17 pm

Billycar11 wrote:
Thu Jul 11, 2019 6:35 pm
feralgoose wrote:
Thu Jul 11, 2019 5:45 pm
Just to add, as far as I can tell, the drive is still reading disks.
Me and puddingistastyapples are the same person on YouTube here is the better place to post

It's good that it still reads disks. The next thing to try is on a different PC and if they does not work then direct sata connection and if you can't do that you can always send it to me or buy one from me.
I tried a PC and two laptops. On the second laptop I noticed lots of connect/disconnect noises in rapid succession leading me to think there was a problem with the enclosure. I went to Micro Center and picked up what I needed to go direct to SATA in my PC and low and behold it worked! Thanks for the help everyone! I will either be returning or exchanging my enclosure. Any advice there? I could try the same one again (Vantec Slim SATA Optical Drive Enclosure NST-510S3-BK) but I probably don't have the need for the ability to flash firmware at this point, so maybe something faster (if possible) is better. Thanks again!

Billycar11
Posts: 476
Joined: Sun Aug 24, 2014 5:49 am

Re: BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by Billycar11 » Thu Jul 11, 2019 10:50 pm

feralgoose wrote:
Thu Jul 11, 2019 10:17 pm
Billycar11 wrote:
Thu Jul 11, 2019 6:35 pm
feralgoose wrote:
Thu Jul 11, 2019 5:45 pm
Just to add, as far as I can tell, the drive is still reading disks.
Me and puddingistastyapples are the same person on YouTube here is the better place to post

It's good that it still reads disks. The next thing to try is on a different PC and if they does not work then direct sata connection and if you can't do that you can always send it to me or buy one from me.
I tried a PC and two laptops. On the second laptop I noticed lots of connect/disconnect noises in rapid succession leading me to think there was a problem with the enclosure. I went to Micro Center and picked up what I needed to go direct to SATA in my PC and low and behold it worked! Thanks for the help everyone! I will either be returning or exchanging my enclosure. Any advice there? I could try the same one again (Vantec Slim SATA Optical Drive Enclosure NST-510S3-BK) but I probably don't have the need for the ability to flash firmware at this point, so maybe something faster (if possible) is better. Thanks again!
glad it worked out i would just get another enclosure if you dont want to keep the direct connection none are going to be faster the vantec already maxes out that drive 6x max rip speed

feralgoose
Posts: 8
Joined: Wed Jul 10, 2019 11:10 pm

Re: BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by feralgoose » Thu Jul 11, 2019 10:56 pm

Billycar11 wrote:
Thu Jul 11, 2019 10:50 pm
feralgoose wrote:
Thu Jul 11, 2019 10:17 pm
Billycar11 wrote:
Thu Jul 11, 2019 6:35 pm


Me and puddingistastyapples are the same person on YouTube here is the better place to post

It's good that it still reads disks. The next thing to try is on a different PC and if they does not work then direct sata connection and if you can't do that you can always send it to me or buy one from me.
I tried a PC and two laptops. On the second laptop I noticed lots of connect/disconnect noises in rapid succession leading me to think there was a problem with the enclosure. I went to Micro Center and picked up what I needed to go direct to SATA in my PC and low and behold it worked! Thanks for the help everyone! I will either be returning or exchanging my enclosure. Any advice there? I could try the same one again (Vantec Slim SATA Optical Drive Enclosure NST-510S3-BK) but I probably don't have the need for the ability to flash firmware at this point, so maybe something faster (if possible) is better. Thanks again!
glad it worked out i would just get another enclosure if you dont want to keep the direct connection none are going to be faster the vantec already maxes out that drive 6x max rip speed
Alright I'll try one more of the same model. Seems like most people have good luck with them.

asmcom
Posts: 62
Joined: Tue Apr 02, 2019 3:26 pm
Location: United Kingdom

Re: BU40N 1.03 to MK 1.03 - Not sure where to go from here

Post by asmcom » Fri Jul 19, 2019 7:28 pm

I have flashed over 200 x LG-BU40N drives. All the drives I have received come on firmware v1.03.

Straight forward flash to v1.03mk with mini sata connector.

https://www.makemkv.com/forum/viewtopic.php?t=19422

I have not experienced any failures.

PM me if you want clarification.

LG-BU40N now on offer £99.00 only 50 drives available at this price.

Asmcom

Post Reply