Page 1 of 1

Can a UHD disc kill a drive?

Posted: Sat Oct 05, 2019 1:00 pm
by VarHD
Recently, one of my drives - the LG BH16NS55 - stopped reading Blu-ray discs. Not just 4K, but also regular BDs. It happened right after I tried to rip a 4K disc and it failed at the stage where it reads the disc's contents. It started to show some errors so I decided to stop the process, tried again and this time it no longer even recognized the disc. After further testing it turns out that now it's no longer reading ANY BDs.

Luckily, I also had my second drive - the ASUS BW-16D1HT. Today I just ripped one 4K disc successfully, wanted to rip the next one and a similar thing happened. It started to throw some read errors when reading the disc's content, I stopped the process and now it will no longer read any BDs at all - neither 4K, nor regular 1080p ones.

In both cases it happened exactly under the same circumstances, right after a failed attempt to read a UHD disc which makes me wonder - is it really just a coincidence and both drives were "meant to die" or can something like this actually kill a drive?

I have to add that the ASUS is my older drive and I ripped almost my entire library with it, I bought the LG later, didn't rip too much with it so I'm surprised it died so fast.


Oh wow. I just re-flashed the drive's FW because I have nothing to lose at this point... and now the drive is functional again. Anyway, I'll leave this post here just in case someone with a similar issue Googles it thinking their drive is completely dead.

Re: Can a UHD disc kill a drive?

Posted: Wed Oct 09, 2019 11:51 pm
by CSmuggler
I'm now having the same problem with my ASUS BW-16D1HT.

I've only read maybe a dozen discs in this drive at all. I've now had it a year.

Now it won't read any discs at all.

I flashed it with 3.01MK, and it still doesn't work.

Can you say specifically what firmware you used to flash the ASUS?

I hope this will be fixes, and yeah, I wonder if its a UHD disc issue.

Re: Can a UHD disc kill a drive?

Posted: Thu Oct 10, 2019 11:07 am
by VarHD
CSmuggler wrote:
Wed Oct 09, 2019 11:51 pm
Can you say specifically what firmware you used to flash the ASUS?
Originally I've been using the MK 3.10 firmware and after the drive crapped out, I downgraded to 3.02, but not the MK release, I used the DE version instead, that is - DE_ASUS_BW-16D1HT_3.02.bin from this pack: ... and that brought it back to life.

BTW, when you do this make sure to test it with a regular 1080p Blu-ray disc just to check if it recognizes/mounts it because I've had situations where a UHD disc would only load/mount after 2-3 tries.

Re: Can a UHD disc kill a drive?

Posted: Wed Oct 23, 2019 11:47 am
by matfid
Thanks VarHD. I just had this very same thing happen to me (after trying to rip 4k Mission Impossible Fallout). Downgraded to DE 3.02 and now it all functions again.

Much appreciated.


Re: Can a UHD disc kill a drive?

Posted: Wed Oct 23, 2019 4:08 pm
by CSmuggler
Nothing revived my drive.

I reinstalled my original firmware, then updated it to stock, and latest version, and it still wouldn't read.

I've returned it under RMA for repair/replacement.

Hopefully this will be resolved soon. I hate getting duds!