Bricked BC-12B1ST by flashing to BW-16D1HT 3.02

Discussion of LibreDrive mode, compatible drives and firmwares
Post Reply
Posts: 1
Joined: Tue Sep 03, 2019 8:50 am

Bricked BC-12B1ST by flashing to BW-16D1HT 3.02

Post by imstupid » Tue Sep 03, 2019 9:34 am

Sorry, I'm stupid, following one suggestion in one comment in a thread here, and I brick my BC-12B1ST. It was at 1.00 and I tried to flash it with BW-16D1HT 3.02, obtained in ... 873#p70282 with the software from ... 873#p70284

By brick I mean now the drive is recognized as BW-16D1HT 3.02. But putting any disc in it and makemkv still says there's no disc inside.

I tried to fix it in various ways and all doesn't work:

- download the latest official BC-12B1ST firmware 3.11

- install this directly

- or extract it using Firmware Extractor 2 from and use the software

- flash a "sister" model BW-12B1ST original 1.0 firmware to it (found on internet, and I use BW-12B1ST because I can't find one for the BC-12B1ST.)

- flash various firmwares from ... 16&t=18933 with its modified ASUS Flasher

In all these cases in the end it fails, having something like error 1117.

I guess someone has been in my shoes, is there any way to unbrick it? (I did not have my original firmware.) From ... 1ST#p72200 it seems the chance is slim. Would it be possible to buy exactly the same model (2014 version) and try to get the firmware from that unit and flash on this one? I heard something on the net that this won't work because there's laser calibration data, etc. Is it true?

(Yes, I'm stupid. For that I know.)


Posts: 633
Joined: Tue Mar 06, 2018 11:38 pm

Re: Bricked BC-12B1ST by flashing to BW-16D1HT 3.02

Post by st4evr » Tue Sep 03, 2019 3:12 pm

Read this: ... 16&t=19071

The same process should apply to you/your drive if it’s not already in an unrecoverable state.
AND you’ll have to find the proper original firmware for your drive to proceed with that DOSflash method if at all possible.

Otherwise save yourself the headache and buy a new drive.

Post Reply