Optical Drive not being found

The place to discuss linux version of MakeMKV
agressiv
Posts: 3
Joined: Sun Mar 17, 2013 3:07 pm

Re: Optical Drive not being found

Post by agressiv » Tue Jul 24, 2018 8:28 pm

Hello, I'm still having this problem. <snip>

For me, it's permissions, as downgrading to 1.10.8 didn't help.

makemkvcon shows drives when run as sudo, but not as a regular user. I've even added myself to the optical group, but I shouldn't have to do that.

Running arch linux. Anyone have any ideas? I don't want to run makemkv as root.

Edit: had to chmod 777 sr0 and sg4. Seems strange that I'd have to do that, but I'll deal with it later.

crhrwc
Posts: 15
Joined: Tue Jan 22, 2019 11:48 pm

Re: Optical Drive not being found

Post by crhrwc » Tue Apr 09, 2019 4:24 pm

I came looking here because I had a similar problem, "can't find any usable optical drives". In my case, I'm using makemkv inside VNC (Linux, Fedora 29).

And the fix was "chmod a+rw /dev/sg1"

Hopefully folks Googling VNC, MakeMKV, and doesn't work will hit on this solution :)
Fedora Linux.
What's a "Windows?"

alisonken1
Posts: 2
Joined: Thu May 02, 2019 10:17 pm

Re: Optical Drive not being found

Post by alisonken1 » Thu May 02, 2019 10:22 pm

Fedora 29
MakeMKV 1.14.3


I have a bluray USB drive (/dev/sr1), but MakeMKV only shows the installed DVD drive (/dev/sr0).

I know the drive works since I used VLC to play dvd's.

Is there a setting somewhere that I missed that can tell MakeMKV where the bluray drive is?

dnlaua
Posts: 1
Joined: Thu Jul 18, 2019 4:43 am

Re: Optical Drive not being found

Post by dnlaua » Thu Jul 18, 2019 4:45 am

Figured it out after trying to use

Code: Select all

downgrade makemkv
and reading the error message.
First type

Code: Select all

su
Then type password.
Then type

Code: Select all

echo sg > /etc/modules-load.d/sg.conf
Then

Code: Select all

reboot
Worked like a charm
Note I'm on Manjaro, so you may need a different folder than modules-load.d.

crhrwc
Posts: 15
Joined: Tue Jan 22, 2019 11:48 pm

Re: Optical Drive not being found

Post by crhrwc » Sun Aug 18, 2019 7:48 pm

Another related problem, check and see if there are zombie makemkvcon processes. If so, they will lock up the drive and when you run makemkv again it can't find any drives.

Only fix I know is to use an external drive (buy a USB3 external case), and power it off/on. This will clear the zombies and next run of makemkv will see your drive as normal.
Fedora Linux.
What's a "Windows?"

jeffmnelson
Posts: 1
Joined: Tue Oct 01, 2019 11:14 pm

Re: Optical Drive not being found

Post by jeffmnelson » Tue Oct 01, 2019 11:24 pm

I am running MakeMKV v1.14.5 linux(x64-release) on Ubuntu 19.04. I have tried everything in this thread and have been Googling for hours to no avail. I've tried loading sg using the instructions but didn't really get anywhere. I can confirm that I have two optical drives (/dev/sg1 and /dev/sg7). They both mount fine within the Ubuntu environment but won't pick up in MakeMKV. The issue started when I updated to the latest version. After exhausting every option, I even tried a clean Ubuntu install - still nothing. There has been a lot of mentions of Docker Containers which is totally new to me. I just installed MakeMKV through the Ubuntu Software store so...

Anyway, I am totally out of ideas and could really use a little direction. Anything anyone can suggest would be much appreciated.

alisonken1
Posts: 2
Joined: Thu May 02, 2019 10:17 pm

Re: Optical Drive not being found

Post by alisonken1 » Fri Oct 04, 2019 11:43 am

Just updated to Fedora 30 and purchased ($50) MakeMKV

Fedora 30 (x86-64)
MakeMKV 1.14.5

Code: Select all

root> lssci
[0:0:0:0]    disk    ATA      ST500DM002-1BD14 HP73  /dev/sda 
[1:0:0:0]    cd/dvd  PLDS     DVD+-RW DS-8A8SH KD13  /dev/sr0 
[2:0:0:0]    disk    ATA      WDC WDS200T2B0B  90WD  /dev/sdb 
[6:0:0:0]    cd/dvd  Optiarc  BD ROM BC-5500A  1.86  /dev/sr1 
I was hoping that the purchased copy would help with finding the USB bluray drive. Looks like it's still a waiting game for Fedora types.

mhadi
Posts: 2
Joined: Thu Sep 12, 2019 12:42 am

Re: Optical Drive not being found

Post by mhadi » Wed Oct 30, 2019 3:00 am

Hey Mike,

I'm having the same issues here with the drive not being found.

Fresh Install: Ubuntu 18.04.3 LTS (Desktop)
Makemkv 1.14.5:
I've tried installing from the Ubuntu Software module, and I've tried manually installing (snap install makemkv)... both with the same results.

Both /dev/sr0 and /dev/sg8 were present after install.

Code: Select all

root@:/dev# lsscsi -g
[0:0:0:0]    disk    ATA      ST1000NM0018-2F2 EA04  /dev/sda   /dev/sg0 
[0:0:2:0]    disk    ATA      WDC WD5000AAKX-6 1H18  /dev/sdb   /dev/sg1 
[0:0:3:0]    disk    ATA      WDC WD5000AAKX-6 1H18  /dev/sdc   /dev/sg2 
[0:0:6:0]    disk    ATA      WDC WD5000AAKX-6 1H18  /dev/sdd   /dev/sg3 
[0:0:7:0]    disk    ATA      WDC WD5000AAKX-6 1H18  /dev/sde   /dev/sg4 
[0:0:32:0]   enclosu DP       BP14G+           4.27  -          /dev/sg5 
[3:0:0:0]    disk    ATA      ST1000LM024 HN-M 0001  /dev/sdf   /dev/sg6 
[4:0:0:0]    disk    ATA      ST1000LM024 HN-M 0001  /dev/sdg   /dev/sg7 
[5:0:0:0]    cd/dvd  HL-DT-ST BD-RE  WH16NS60  1.00  /dev/sr0   /dev/sg8 
[6:0:0:0]    disk    ATA      Samsung SSD 860  3B6Q  /dev/sdh   /dev/sg9 

root@:/dev# hexdump -C /sys/bus/scsi/devices/5:0:0:0/inquiry
00000000  05 80 05 32 5b 00 00 00  48 4c 2d 44 54 2d 53 54  |...2[...HL-DT-ST|
00000010  42 44 2d 52 45 20 20 57  48 31 36 4e 53 36 30 20  |BD-RE  WH16NS60 |
00000020  31 2e 30 30 4e 30 30 30  35 30 30 4d 30 36 4a 34  |1.00N000500M06J4|
00000030  41 46 34 34 33 36 20 20  00 00 00 00 00 00 00 00  |AF4436  ........|
00000040  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
00000060

root@:/dev# ls -Fla /dev/sr0
brwxrwxrwx+ 1 root cdrom 11, 0 Oct 29 19:19 /dev/sr0

root@:/dev# ls -Fla /dev/sg8
crwxrwxrwx+ 1 root cdrom 21, 8 Oct 29 19:11 /dev/sg8

I've tried everything listed here, and still get the dreaded: "The program can't find any usable optical drives."

Any help would be greatly appreciated.

mhadi
Posts: 2
Joined: Thu Sep 12, 2019 12:42 am

Re: Optical Drive not being found

Post by mhadi » Wed Oct 30, 2019 2:42 pm

Please disregard my previous post, issue resolved.

To everyone who is experiencing this issue on Ubuntu....

Run

Code: Select all

snap version
snapd MUST be 2.41 or higher.

Run

Code: Select all

snap refresh
As soon as I did this, MakeMKV sees the drive.

troyBORG
Posts: 18
Joined: Wed Mar 23, 2016 4:47 am

Re: Optical Drive not being found

Post by troyBORG » Sun Dec 01, 2019 5:25 pm

I have to do this every system reboot:

sudo modprobe sg

Then it will see the drive.

marknate24
Posts: 5
Joined: Sat Jan 11, 2020 7:01 pm

Re: Optical Drive not being found

Post by marknate24 » Sun Jan 12, 2020 6:56 am

on Pop_os 19.10 with makemkv 1.14.7 and a usb bd reader.
snap is 2.41
sudo modprobe sg didn't seem to do anything

****@pop-os:~$ lsscsi -g
[0:0:0:0] disk ATA Samsung SSD 860 2B6Q /dev/sda /dev/sg0
[1:0:0:0] disk ATA TS512GMTS400 9A /dev/sdb /dev/sg1
[2:0:0:0] cd/dvd MATSHITA BD-CMB UJ141AL 1.00 /dev/sr0 /dev/sg2

Still the no disk found message.

sudo lshw returned this with regards to the drive

Code: Select all

*-usbhost:1
                product: xHCI Host Controller
                vendor: Linux 5.3.0-7625-generic xhci-hcd
                physical id: 1
                bus info: usb@2
                logical name: usb2
                version: 5.03
                capabilities: usb-3.00
                configuration: driver=hub slots=6 speed=5000Mbit/s
              *-usb
                   description: Mass storage device
                   product: Ext. HDD
                   vendor: Innostor Technology Corporation
                   physical id: 3
                   bus info: usb@2:3
                   logical name: scsi2
                   version: 0.36
                   serial: 20190824
                   capabilities: usb-3.00 scsi emulated scsi-host
                   configuration: driver=usb-storage maxpower=800mA speed=5000Mbit/s
                 *-cdrom
                      description: DVD-RAM writer
                      product: BD-CMB UJ141AL
                      vendor: MATSHITA
                      physical id: 0.0.0
                      bus info: scsi@2:0.0.0
                      logical name: /dev/cdrom
                      logical name: /dev/cdrw
                      logical name: /dev/dvd
                      logical name: /dev/dvdrw
                      logical name: /dev/sr0
                      logical name: /media/****/Hinamatsuri_D1
                      version: 1.00
                      capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
                      configuration: mount.fstype=udf mount.options=ro,nosuid,nodev,relatime,uid=1000,gid=1000,iocharset=utf8 state=mounted status=ready
                    *-medium
                         physical id: 0
                         logical name: /dev/cdrom
                         logical name: /media/****/Hinamatsuri_D1
                         configuration: mount.fstype=udf mount.options=ro,nosuid,nodev,relatime,uid=1000,gid=1000,iocharset=utf8 state=mounted

cmastro
Posts: 6
Joined: Thu Oct 03, 2019 5:36 pm

Re: Optical Drive not being found

Post by cmastro » Sun Jun 07, 2020 7:32 pm

crhrwc wrote:
Sun Aug 18, 2019 7:48 pm
Another related problem, check and see if there are zombie makemkvcon processes. If so, they will lock up the drive and when you run makemkv again it can't find any drives.

Only fix I know is to use an external drive (buy a USB3 external case), and power it off/on. This will clear the zombies and next run of makemkv will see your drive as normal.
Glad it worked for you. No luck here (1.15.1 and Ubu18)

nastyjungle
Posts: 2
Joined: Tue Jul 14, 2020 2:22 am

Re: Optical Drive not being found

Post by nastyjungle » Tue Jul 14, 2020 2:39 am

Ubuntu 18.04.4 LTS x86_64, was using 1.15.1 and then like the lot of you, makemkv no worky worky now.

Read this thread, installed 1.12.3 (1.12.0 I did not see on http://www.makemkv.com/download/old/)

Fired up makemkv get some fun errors:
Error 'Scsi error - ILLEGAL REQUEST:COPY PROTECTION KEY EXCHANGE FAILURE - AUTHENTICATION FAILURE' occurred
Error 'Scsi error - ILLEGAL REQUEST:COPY PROTECTION KEY EXCHANGE FAILURE - KEY NOT ESTABLISHED' occurred w
Can't read AACS VID from disc - most likely current AACS host certificate is revoked by your drive

damnit!

Just for giggles I opened 1.15.1 back up, and it seems to be working for now.

What should I do when this stops working again? Should I post any logs or what? (am linux newb)


edit: has stopped working again after i put in the next disc

nastyjungle
Posts: 2
Joined: Tue Jul 14, 2020 2:22 am

Re: Optical Drive not being found

Post by nastyjungle » Tue Jul 14, 2020 7:48 pm

This is my current error on repeat:

Error 'Scsi error - MEDIUM ERROR:UNRECOVERED READ ERROR - AUTO REALLOCATE FAILED' occurred while issuing SCSI command 460200100..00100 to device 'SG:dev_21:5'

Post Reply