Works in GUI not in CLI

The place to discuss linux version of MakeMKV
Post Reply
razzam21
Posts: 2
Joined: Wed Mar 14, 2018 5:11 am

Works in GUI not in CLI

Post by razzam21 » Fri Mar 20, 2020 2:33 am

When I run this command:

Code: Select all

makemkv.makemkvcon -r --debug --directio=true info iso:/mnt/encoding/rips/ABOMINABLE.ISO
I get this error:
MSG:5042,0,0,"The program can't find any usable optical drives.","The program can't find any usable optical drives."
MSG:1003,32,3,"DEBUG: Code 13 at d>6><rI<\\fk[SXmrUTi|_L:121261658","DEBUG: Code %1 at %2:%3","13","d>6><rI<\\fk[SXmrUTi|_L","121261658"
MSG:5007,0,1,"Failed to open file /mnt/encoding/rips/ABOMINABLE.ISO","Failed to open file %1","/mnt/encoding/rips/ABOMINABLE.ISO"
MSG:1003,32,3,"DEBUG: Code 233 at gTL2a+MH9VQ2VL3OT6Kf8WI1:0","DEBUG: Code %1 at %2:%3","233","gTL2a+MH9VQ2VL3OT6Kf8WI1","0"
MSG:5010,0,0,"Failed to open disc","Failed to open disc"

But I am able to load the file manually in the GUI and the disc will be recognized and work just fine.

I am trying to write a script that can automatically convert all of my ISOs into MKVs.

I also tried (thinking that maybe "info" was just sensitive):

Code: Select all

makemkv.makemkvcon -r --debug --directio=true mkv iso:/mnt/encoding/rips/ABOMINABLE.ISO all /mnt/encoding/mkvs/
I get this error when I run that:
MSG:5042,0,0,"The program can't find any usable optical drives.","The program can't find any usable optical drives."
MSG:1003,32,3,"DEBUG: Code 13 at d>6><rI<\\fk[SXmrUTi|_L:121261658","DEBUG: Code %1 at %2:%3","13","d>6><rI<\\fk[SXmrUTi|_L","121261658"
MSG:5007,0,1,"Failed to open file /mnt/encoding/rips/ABOMINABLE.ISO","Failed to open file %1","/mnt/encoding/rips/ABOMINABLE.ISO"
MSG:1003,32,3,"DEBUG: Code 233 at 86a8rJ1HAhZmAmOf7R7rzW7h:0","DEBUG: Code %1 at %2:%3","233","86a8rJ1HAhZmAmOf7R7rzW7h","0"
MSG:5010,0,0,"Failed to open disc","Failed to open disc"

I would appreciate any help.
Thanks

diddledan
Posts: 1
Joined: Mon Mar 30, 2020 3:56 pm

Re: Works in GUI not in CLI

Post by diddledan » Mon Mar 30, 2020 3:59 pm

Make sure you have given the MakeMKV Snap permission to access

Code: Select all

/mnt
with the following command in a terminal:

Code: Select all

sudo snap connect makemkv:removable-media
If that is already connected then it might be that I have made a mistake in the package (yes, I'm the author of that Snap).

Post Reply