openssl test 00FC failed

The place to discuss linux version of MakeMKV
Post Reply
xr200
Posts: 42
Joined: Tue Nov 10, 2015 3:11 am

openssl test 00FC failed

Post by xr200 » Tue Mar 12, 2019 7:41 pm

I've been compiling MakeMKV from source on a desktop running PCLinuxOS for a few years.
I was running version 14.1 and did a full backup of that desktop. I upgraded to 14.2 a while
back with no problem, but never did another backup. 14.2 was working fine. Today I tried
to upgrade to 14.3. It compiled fine, but when I tried to run it, I got a popup saying
"Failed to initialize program." I fixed that by deleting my $HOME/.MakeMKV directory.
Now (running 14.3), I get the "openssl test 00FC failed" error and the program aborts.

I went and recompiled 14.2, and I get the same 00FC error when running MakeMKV.
The same is true for 14.1: it compiles fine, but when I run MakeMKV I get the openssl
00FC error.

I went to my 14.1 backup and reinstalled version 14.1 from the backup to the desktop,
and it's working fine. I don't want to be stuck on version 14.1 (that I can't even
reproduce).

It's possible that I updated the system software on the desktop after I had originally
built a working version of 14.2. I do that every month or so. I'm certain that I have openssl
and the dev headers installed. That's the only thing that I can figure would cause me to
no longer be able to build a working version of 14.2, but I might be barking up the
wrong tree.

How can I determine what's the cause of this "openssl test 00FC" error when
executing makemkv?

xr200
Posts: 42
Joined: Tue Nov 10, 2015 3:11 am

Re: openssl test 00FC failed

Post by xr200 » Wed Mar 13, 2019 2:14 am

I've learned the problem is related to the version of openssl. Previously, when
everything was working for me, openssl was on version 1.0.2m.
PCLinuxOS jumped the version to 1.1.0j, and when makemkv is compiled
against 1.1.0j (on PCLinuxOS anyway, can't speak to any other distribution),
makemkv will compile but give spit out this cryptic error and abort.

Luckily for me, I had an old backup with 1.0.2m on it, and I was able
to build makemkv 14.3 on that backup. I then installed that version
on my normal platform (using openssl 1.1.0j) and it seems to be
running fine.

I don't know why this is happening, nor do I wish to guess where the
problem is.

Are there any Linux users running other distributions who have built
makemkv 14.3 using openssl 1.1.0 or above and makemkv works?

Post Reply