Page 1 of 1

VLC Media Player won't play blu-ray's in Ubuntu 20.04? (Running latest MakeMKV)

Posted: Wed May 27, 2020 12:15 pm
by Skull Kid
Hello all,

I'm trying to get The Texas Chain Saw Massacre (1974) to play in Ubuntu 20.04 through VLC Media Player (latest version) and MakeMKV is also in it's latest version on my computer. I've made symbolic links from "" to /usr/lib, but as of now, nothing seems to play. My drive is an Asus BW-12B1ST, version 1.03.

Any clues? Any help is appreciated!

Thanks in advance.

Kind regards,

Skull Kid

EDIT: I haven't solved it, but for various reasons, I've switched back to Windows 10 and the issue is gone now.

Re: VLC Media Player won't play blu-ray's in Ubuntu 20.04? (Running latest MakeMKV)

Posted: Wed Jun 03, 2020 5:30 pm
by timeshifter
Debian, Ubuntu and derivatives have been supporting multiple architectures using a Multiarch layout ( for many years now. The instructions for adding libmmbd support are outdated/incomplete.

The correct place to put the symlink on modern 64-bit Debian-based systems is in "/usr/lib/86_64-linux-gnu/", not "/usr/lib".

If you install MakeMKV using the Ubuntu PPA ( ... kemkv-beta), the libmmbd library is installed at "/usr/lib/x86_64-linux-gnu/", and VLC Media Player plays blu-rays without additional configuration.

Re: VLC Media Player won't play blu-ray's in Ubuntu 20.04? (Running latest MakeMKV)

Posted: Thu Jun 04, 2020 12:49 pm
by georgesgiralt
I run VLC (version on a 20.04LTS Ubuntu platform upgraded from 19.10. I was able to play BluRay discs on this machine (but with a different BD device).
Now, it is not working any more.
I've installed the latest beta key, and MakeMkv is accessing the disc.
Vlc complains about AACS not found :

Code: Select all

Erreur Blu-ray:
Fichier de configuration AACS manquant !
Votre média d'entrée ne peut être ouvert:
VLC ne peut pas ouvrir « bluray:///dev/sr0 ». Vérifier les messages du journal pour plus de détails.
The library is at the correct place (because I used the PPA to install MakeMkv) :

Code: Select all

# ll /usr/lib/x86_64-linux-gnu/
-rw-r--r-- 1 root root 47504 avril 18 20:39 /usr/lib/x86_64-linux-gnu/
As you can see, the library predates my upgrade to 20.04.
I've checked, I've no link left in /usr/lib
Could you please help me ? Or point me to a solution ?
Many thanks in advance for your help.
Have a nice day and stay safe !

Re: VLC Media Player won't play blu-ray's in Ubuntu 20.04? (Running latest MakeMKV)

Posted: Mon Jun 15, 2020 4:23 am
by belmakier
It may be worth trying to install MakeMKV from source: viewtopic.php?f=3&t=224

This installs the library directly in /usr/lib.

I had an issue with VLC crashing when using the library that came with the MakeMKV when installed via snap on Ubuntu 20.04

Re: VLC Media Player won't play blu-ray's in Ubuntu 20.04? (Running latest MakeMKV)

Posted: Fri Aug 21, 2020 5:48 pm
by MetalDave
I've got an interesting one for you all. I'm running a clean install of Ubuntu 20.04, and I've been trying to find the right combination of MakeMKV and VLC. So far, I'm using VLC installed and running via Snap and MakeMKV which has been installed from source (based upon the post from Mike as cited by belmakier).

I've been trying to troubleshoot VLC's access to /usr/lib/ for a week or so. The read-only filesystem features of the snap installation are desirable from a security and runtime perspective. Being the case that VideoLAN is maintaining their snap, this seems to be the recommended way to install, and I'd like to stick with that if possible. Of course, this makes it challenging to override VLC's library usage via strategic symlinks to libmmbd. I've been picking their brain over at the VideoLAN forum as well.

In the course of my analysis, I found something curious (thanks to the posts in this thread). When I looked at the following:

Code: Select all

~$ ll /usr/lib/x86_64-linux-gnu/libmmbd*
lrwxrwxrwx 1 root root     14 Aug 19 06:16 /usr/lib/x86_64-linux-gnu/ ->	# Symlink created by what?
I found a symlink pointing to The date of my compile and install of MakeMKV was August 11th, so I know that wasn't placed by that installation. Unless I was really tired one night and accidentally created this symlink (unlikely), I cannot figure out what would have created this.

For comparison, my actual /usr/lib/ was installed on August 11th with MakeMKV:

Code: Select all

$ ll /usr/lib/libmmbd*
-rw-r--r-- 1 root root 47688 Aug 11 23:19 /usr/lib/	## Installed by MakeMKV
$ ll /usr/bin/makemkv*
-rwxr-xr-x 1 root root 30669960 Aug 11 23:19 /usr/bin/makemkv*
-rwxr-xr-x 1 root root  6023048 Aug 11 23:28 /usr/bin/makemkvcon*
I don't know if the VLC install is the culprit either as my copy is from August 17th.

Code: Select all

$ ll /var/lib/snapd/snaps/vlc*
-rw------- 2 root root 304545792 Aug 17 20:58 /var/lib/snapd/snaps/vlc_1700.snap
Either way, this symlink to libbdplus seems like the complete opposite of what we want to do with libmmbd. I don't know why I would have created it, so I'm curious to know how it got there. Has anyone else seen this magically appear on their system?

Ultimately, I'm not getting VLC to play Blu-ray discs directly at this point. I may look into compiling VLC instead of using the snap install (which would allow me to create a libaacs and libbdplus symlink to libmmbd and get things working), but I'd really like to stick with the convenience of the snap method. I'd appreciate any suggestions or thoughts on this as well.

Re: VLC Media Player won't play blu-ray's in Ubuntu 20.04? (Running latest MakeMKV)

Posted: Fri Aug 21, 2020 6:02 pm
by MetalDave
Incidentally, here's my output from running "make install" with makemkv-bin-1.15.2

Code: Select all

$ sudo make install
rm -f /usr/bin/makemkvcon
rm -f /usr/bin/mmdtsdec
rm -f /usr/share/MakeMKV/*
install -d /usr/share/MakeMKV
install -d /usr/bin
install -t /usr/bin bin/amd64/makemkvcon
install -m 644 -t /usr/share/MakeMKV src/share/appdata.tar
install -m 644 -t /usr/share/MakeMKV src/share/blues.jar
install -m 644 -t /usr/share/MakeMKV src/share/blues.policy
cd /usr/bin && ln -s -f makemkvcon sdftool
Dates and times are consistent with the MakeMKV installation as mentioned in my earlier post.

Code: Select all

$ ll /usr/bin/makemkvcon 
-rwxr-xr-x 1 root root 6023048 Aug 11 23:28 /usr/bin/makemkvcon*
$ ll /usr/bin/sdftool 
lrwxrwxrwx 1 root root 10 Aug 11 23:28 /usr/bin/sdftool -> makemkvcon*cd ..
I also looked through the Makefile for makemkv-oss-1.15.2, and the only action for libmmbd was to install it as /usr/lib/ (no symlinks created).