unable to upgrade to 1.8.6

The place to discuss linux version of MakeMKV
Post Reply
mrreload
Posts: 9
Joined: Mon Aug 02, 2010 8:37 pm

unable to upgrade to 1.8.6

Post by mrreload » Mon Nov 11, 2013 5:54 pm

The bin will install fine. The oss package will not. make fails as shown below:
Ubuntu 12.04LTS amd64, have been able to compile MakeMKV on this same box for years.

Please help

make -f makefile.linux
mkdir -p out
gcc -Os -D_GNU_SOURCE -D_linux_ -D_REENTRANT -shared -Wl,-z,defs -oout/libdriveio.so.0.full -Ilibdriveio/inc libdriveio/src/infolist.cpp libdriveio/src/scsihlp.cpp libdriveio/src/srlist.cpp libdriveio/src/stdquery.cpp libdriveio/src/tipclient.cpp libdriveio/src/tipcommon.cpp libdriveio/src/tipserver.cpp libdriveio/src/drives/pioneer.cpp libdriveio/src/drives/xboxhddvd.cpp \
-fPIC -Xlinker -dy -Xlinker --version-script=libdriveio/src/libdriveio.vers \
-Xlinker -soname=libdriveio.so.0 -lc -lstdc++
objcopy --strip-all --strip-debug --strip-unneeded --discard-all out/libdriveio.so.0.full out/libdriveio.so.0
mkdir -p tmp
echo "#define BUILDINFO_ARCH_NAME \"x86_64-linux-gnu\"" >> tmp/gen_buildinfo.h
echo "#define BUILDINFO_BUILD_DATE \"Mon Nov 11 09:48:53 PST 2013\"" >> tmp/gen_buildinfo.h
mkdir -p out
gcc -Os -D_GNU_SOURCE -D_linux_ -D_REENTRANT -shared -Wl,-z,defs -oout/libmakemkv.so.1.full -Ilibebml/inc -DEBML_NO_READ -DEBML_STRICT_API -Ilibmatroska/inc \
-Ilibmakemkv/inc -Isstring/inc -Imakemkvgui/inc -Ilibabi/inc -Ilibffabi/inc \
libebml/src/EbmlBinary.cpp libebml/src/EbmlContexts.cpp libebml/src/EbmlCrc32.cpp libebml/src/EbmlDate.cpp libebml/src/EbmlDummy.cpp libebml/src/EbmlElement.cpp libebml/src/EbmlFloat.cpp libebml/src/EbmlHead.cpp libebml/src/EbmlMaster.cpp libebml/src/EbmlSInteger.cpp libebml/src/EbmlString.cpp libebml/src/EbmlSubHead.cpp libebml/src/EbmlUInteger.cpp libebml/src/EbmlUnicodeString.cpp libebml/src/EbmlVersion.cpp libebml/src/EbmlVoid.cpp libebml/src/IOCallback.cpp libebml/src/MemIOCallback.cpp libmatroska/src/FileKax.cpp libmatroska/src/KaxAttached.cpp libmatroska/src/KaxAttachments.cpp libmatroska/src/KaxBlock.cpp libmatroska/src/KaxBlockData.cpp libmatroska/src/KaxChapters.cpp libmatroska/src/KaxCluster.cpp libmatroska/src/KaxClusterData.cpp libmatroska/src/KaxContentEncoding.cpp libmatroska/src/KaxContexts.cpp libmatroska/src/KaxCues.cpp libmatroska/src/KaxCuesData.cpp libmatroska/src/KaxInfo.cpp libmatroska/src/KaxInfoData.cpp libmatroska/src/KaxSeekHead.cpp libmatroska/src/KaxSegment.cpp libmatroska/src/KaxTag.cpp libmatroska/src/KaxTags.cpp libmatroska/src/KaxTrackAudio.cpp libmatroska/src/KaxTrackEntryData.cpp libmatroska/src/KaxTracks.cpp libmatroska/src/KaxTrackVideo.cpp libmatroska/src/KaxVersion.cpp libmakemkv/src/ebmlwrite.cpp libmakemkv/src/libmkv.cpp libmakemkv/src/version.cpp libmakemkv/src/world.cpp sstring/src/sstring.cpp \
libabi/src/ossl_aes.c libabi/src/ossl_sha.c libabi/src/ossl_ec.c libabi/src/zlib.c libabi/src/xpat.c libabi/pssl/ec_key.c libabi/pssl/ec_lib.c libabi/pssl/ec_cvt.c libabi/pssl/ec_mult.c libabi/pssl/ecp_mont.c libabi/pssl/ecp_smpl.c libabi/pssl/ecs_ossl.c libabi/pssl/ecs_sign.c libabi/pssl/ecs_vrf.c libabi/src/httplinux.cpp makemkvgui/src/api_linux.cpp libabi/src/sys_linux.c makemkvgui/src/spawn_posix.cpp libffabi/src/ffabi.c libffabi/src/mlp.c libffabi/src/log.c libffabi/src/audio_convert.c \
-DHAVE_BUILDINFO_H -Itmp \
-fPIC -Xlinker -dy -Xlinker --version-script=libmakemkv/src/libmakemkv.vers \
-Xlinker -soname=libmakemkv.so.1 -lc -lstdc++ -lcrypto -lz -lexpat -lavcodec -lavutil -lm
In file included from libffabi/src/ffabi.c:24:0:
/usr/local/include/libavutil/samplefmt.h:27:6: error: nested redefinition of ?enum AVSampleFormat?
/usr/local/include/libavutil/samplefmt.h:27:6: error: redeclaration of ?enum AVSampleFormat?
/usr/local/include/libavcore/samplefmt.h:27:6: note: originally defined here
/usr/local/include/libavutil/samplefmt.h:28:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_NONE?
/usr/local/include/libavcore/samplefmt.h:28:5: note: previous definition of ?AV_SAMPLE_FMT_NONE? was here
/usr/local/include/libavutil/samplefmt.h:29:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_U8?
/usr/local/include/libavcore/samplefmt.h:29:5: note: previous definition of ?AV_SAMPLE_FMT_U8? was here
/usr/local/include/libavutil/samplefmt.h:30:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_S16?
/usr/local/include/libavcore/samplefmt.h:30:5: note: previous definition of ?AV_SAMPLE_FMT_S16? was here
/usr/local/include/libavutil/samplefmt.h:31:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_S32?
/usr/local/include/libavcore/samplefmt.h:31:5: note: previous definition of ?AV_SAMPLE_FMT_S32? was here
/usr/local/include/libavutil/samplefmt.h:32:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_FLT?
/usr/local/include/libavcore/samplefmt.h:32:5: note: previous definition of ?AV_SAMPLE_FMT_FLT? was here
/usr/local/include/libavutil/samplefmt.h:33:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_DBL?
/usr/local/include/libavcore/samplefmt.h:33:5: note: previous definition of ?AV_SAMPLE_FMT_DBL? was here
/usr/local/include/libavutil/samplefmt.h:41:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_NB?
/usr/local/include/libavcore/samplefmt.h:34:5: note: previous definition of ?AV_SAMPLE_FMT_NB? was here
libffabi/src/ffabi.c: In function ?static_log_callback?:
libffabi/src/ffabi.c:63:31: error: dereferencing pointer to incomplete type
libffabi/src/ffabi.c: At top level:
libffabi/src/ffabi.c:95:23: error: return type is an incomplete type
libffabi/src/ffabi.c: In function ?translate_codec_id?:
libffabi/src/ffabi.c:97:20: error: storage size of ?r? isn?t known
libffabi/src/ffabi.c:100:33: error: ?AV_CODEC_ID_AC3? undeclared (first use in this function)
libffabi/src/ffabi.c:100:33: note: each undeclared identifier is reported only once for each function it appears in
libffabi/src/ffabi.c:101:33: error: ?AV_CODEC_ID_DTS? undeclared (first use in this function)
libffabi/src/ffabi.c:102:34: error: ?AV_CODEC_ID_FLAC? undeclared (first use in this function)
libffabi/src/ffabi.c:103:33: error: ?AV_CODEC_ID_MLP? undeclared (first use in this function)
libffabi/src/ffabi.c:104:36: error: ?AV_CODEC_ID_TRUEHD? undeclared (first use in this function)
libffabi/src/ffabi.c:105:17: error: ?AV_CODEC_ID_NONE? undeclared (first use in this function)
libffabi/src/ffabi.c:107:5: warning: ?return? with a value, in function returning void [enabled by default]
libffabi/src/ffabi.c: In function ?ffm_audio_decode_init?:
libffabi/src/ffabi.c:142:5: error: unknown type name ?AVDictionary?
libffabi/src/ffabi.c:151:5: error: invalid use of void expression
libffabi/src/ffabi.c:166:15: error: ?AVCodecContext? has no member named ?refcounted_frames?
libffabi/src/ffabi.c:174:15: error: ?AVCodecContext? has no member named ?request_sample_fmt?
libffabi/src/ffabi.c: In function ?ffm_audio_decode_put_data?:
libffabi/src/ffabi.c:240:23: error: ?AVFrame? has no member named ?format?
libffabi/src/ffabi.c:241:23: error: ?AVFrame? has no member named ?format?
libffabi/src/ffabi.c:241:45: error: ?AVCodecContext? has no member named ?request_sample_fmt?
libffabi/src/ffabi.c:243:46: error: ?AVFrame? has no member named ?nb_samples?
libffabi/src/ffabi.c:246:41: error: ?AVFrame? has no member named ?nb_samples?
libffabi/src/ffabi.c: In function ?ffm_audio_encode_init?:
libffabi/src/ffabi.c:296:5: error: unknown type name ?AVDictionary?
libffabi/src/ffabi.c:309:5: error: invalid use of void expression
libffabi/src/ffabi.c:321:15: error: ?AVCodecContext? has no member named ?refcounted_frames?
libffabi/src/ffabi.c: In function ?ffm_audio_encode_put_frame?:
libffabi/src/ffabi.c:391:14: error: ?AVFrame? has no member named ?format?
libffabi/src/ffabi.c:407:14: error: ?AVFrame? has no member named ?nb_samples?
libffabi/src/ffabi.c: In function ?ffm_audio_check_codec_format?:
libffabi/src/ffabi.c:442:9: error: invalid use of void expression
libffabi/src/ffabi.c:444:9: error: invalid use of void expression
libffabi/src/ffabi.c: In function ?ffm_mlp_read_syncframe?:
libffabi/src/ffabi.c:478:34: error: ?AV_CODEC_ID_MLP? undeclared (first use in this function)
libffabi/src/ffabi.c:517:28: error: ?AVCodecParserContext? has no member named ?duration?
In file included from /usr/local/include/libavcodec/avcodec.h:30:0,
from libffabi/src/internal.h:5,
from libffabi/src/mlp.c:27:
/usr/local/include/libavcore/samplefmt.h:27:6: error: nested redefinition of ?enum AVSampleFormat?
/usr/local/include/libavcore/samplefmt.h:27:6: error: redeclaration of ?enum AVSampleFormat?
/usr/local/include/libavutil/samplefmt.h:27:6: note: originally defined here
/usr/local/include/libavcore/samplefmt.h:28:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_NONE?
/usr/local/include/libavutil/samplefmt.h:28:5: note: previous definition of ?AV_SAMPLE_FMT_NONE? was here
/usr/local/include/libavcore/samplefmt.h:29:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_U8?
/usr/local/include/libavutil/samplefmt.h:29:5: note: previous definition of ?AV_SAMPLE_FMT_U8? was here
/usr/local/include/libavcore/samplefmt.h:30:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_S16?
/usr/local/include/libavutil/samplefmt.h:30:5: note: previous definition of ?AV_SAMPLE_FMT_S16? was here
/usr/local/include/libavcore/samplefmt.h:31:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_S32?
/usr/local/include/libavutil/samplefmt.h:31:5: note: previous definition of ?AV_SAMPLE_FMT_S32? was here
/usr/local/include/libavcore/samplefmt.h:32:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_FLT?
/usr/local/include/libavutil/samplefmt.h:32:5: note: previous definition of ?AV_SAMPLE_FMT_FLT? was here
/usr/local/include/libavcore/samplefmt.h:33:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_DBL?
/usr/local/include/libavutil/samplefmt.h:33:5: note: previous definition of ?AV_SAMPLE_FMT_DBL? was here
/usr/local/include/libavcore/samplefmt.h:34:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_NB?
/usr/local/include/libavutil/samplefmt.h:41:5: note: previous definition of ?AV_SAMPLE_FMT_NB? was here
In file included from /usr/local/include/libavcodec/avcodec.h:30:0,
from libffabi/src/internal.h:5,
from libffabi/src/audio_convert.c:34:
/usr/local/include/libavcore/samplefmt.h:27:6: error: nested redefinition of ?enum AVSampleFormat?
/usr/local/include/libavcore/samplefmt.h:27:6: error: redeclaration of ?enum AVSampleFormat?
/usr/local/include/libavutil/samplefmt.h:27:6: note: originally defined here
/usr/local/include/libavcore/samplefmt.h:28:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_NONE?
/usr/local/include/libavutil/samplefmt.h:28:5: note: previous definition of ?AV_SAMPLE_FMT_NONE? was here
/usr/local/include/libavcore/samplefmt.h:29:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_U8?
/usr/local/include/libavutil/samplefmt.h:29:5: note: previous definition of ?AV_SAMPLE_FMT_U8? was here
/usr/local/include/libavcore/samplefmt.h:30:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_S16?
/usr/local/include/libavutil/samplefmt.h:30:5: note: previous definition of ?AV_SAMPLE_FMT_S16? was here
/usr/local/include/libavcore/samplefmt.h:31:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_S32?
/usr/local/include/libavutil/samplefmt.h:31:5: note: previous definition of ?AV_SAMPLE_FMT_S32? was here
/usr/local/include/libavcore/samplefmt.h:32:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_FLT?
/usr/local/include/libavutil/samplefmt.h:32:5: note: previous definition of ?AV_SAMPLE_FMT_FLT? was here
/usr/local/include/libavcore/samplefmt.h:33:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_DBL?
/usr/local/include/libavutil/samplefmt.h:33:5: note: previous definition of ?AV_SAMPLE_FMT_DBL? was here
/usr/local/include/libavcore/samplefmt.h:34:5: error: redeclaration of enumerator ?AV_SAMPLE_FMT_NB?
/usr/local/include/libavutil/samplefmt.h:41:5: note: previous definition of ?AV_SAMPLE_FMT_NB? was here
make: *** [out/libmakemkv.so.1.full] Error 1

crowfax
Posts: 972
Joined: Thu Feb 18, 2010 5:55 am

Re: unable to upgrade to 1.8.6

Post by crowfax » Mon Nov 11, 2013 6:42 pm

Rerun the

Code: Select all

sudo apt-get install build-essential libc6-dev libssl-dev libexpat1-dev libavcodec-dev libgl1-mesa-dev libqt4-dev
command and make sure your packages are up to date. I had a similar issue to you and realised my dependencies needed updating.
Home Theater PC: Assassin HTPC, XBMCbuntu 12.0 (Frodo), Intel i5 3570k 3.4 GHz Ivy Bridge w/ HD 4000, LG BD-ROM
Playback Devices: Mede8er MED600X3D, MyGica EnjoyTV 120, Xtreamer SideWinder 3, Crystal Acoustics MediaMatchBox

mrreload
Posts: 9
Joined: Mon Aug 02, 2010 8:37 pm

Re: unable to upgrade to 1.8.6

Post by mrreload » Mon Nov 11, 2013 6:59 pm

I forgot to mention the build packages were already up to date before I started and I just double checked.

mrreload
Posts: 9
Joined: Mon Aug 02, 2010 8:37 pm

Re: unable to upgrade to 1.8.6

Post by mrreload » Mon Nov 11, 2013 9:44 pm

I also was just able to build the 1.8.5 oss package without errors on the same box. Curiously, I tried 1.8.6 on a fresh VM and it compiled and installed fine. I think I have a conflicting version of something.

tgui9660
Posts: 11
Joined: Fri Oct 25, 2013 12:04 am

Re: unable to upgrade to 1.8.6

Post by tgui9660 » Tue Nov 12, 2013 2:46 am

I haven't been able to build 1.8.5 or 1.8.6 on Ubuntu 12.04 LTS. My thread was met with instructions based on Mac OSX. I haven't a clue where to find dump files to help devs figure things out.

belegdol
Posts: 26
Joined: Mon Mar 05, 2012 5:30 pm

Re: unable to upgrade to 1.8.6

Post by belegdol » Tue Nov 12, 2013 9:17 pm

The fact of the matter is that makemkv-1.8.6 needs very recent ffmpeg. 1.2 does not work, 2.1 does. I am not sure about 2.0.

mike admin
Posts: 3738
Joined: Wed Nov 26, 2008 2:26 am
Contact:

Re: unable to upgrade to 1.8.6

Post by mike admin » Wed Nov 13, 2013 9:48 am

belegdol wrote:The fact of the matter is that makemkv-1.8.6 needs very recent ffmpeg. 1.2 does not work, 2.1 does. I am not sure about 2.0.
1.2 should work in a sense that it will compile and work, but flac encoder will be locked to 16 bit. Do you by any chance still have setup with 1.2 libraries that gives compilation error?

belegdol
Posts: 26
Joined: Mon Mar 05, 2012 5:30 pm

Re: unable to upgrade to 1.8.6

Post by belegdol » Wed Nov 13, 2013 10:04 am

I don't unfortunately, as I upgraded to fedora 20 for this very reason. It was failing with something about avcodeccontext. I can set up a fedora 19 vm if needed.

mike admin
Posts: 3738
Joined: Wed Nov 26, 2008 2:26 am
Contact:

Re: unable to upgrade to 1.8.6

Post by mike admin » Fri Nov 15, 2013 8:00 am

Please do if you can, and try the workaround from http://www.makemkv.com/forum2/viewtopic.php?f=3&t=7215

Post Reply