Blocking/Pixelation encoding issue from Handbrake from MakeMKV DVD source

MKV playback, recompression, remuxing, codec packs, players, howtos, etc.
Post Reply
the1337moderate
Posts: 1
Joined: Sun Jun 23, 2019 7:18 am

Blocking/Pixelation encoding issue from Handbrake from MakeMKV DVD source

Post by the1337moderate » Sun Jun 23, 2019 7:32 am

I am beginning the process of getting my DVD and BD disks onto my Plex server. I am limited on total disk space and as such I am attempting re-encode all of my media files from the MakeMKV generated .mkv file to a smaller .mkv file using Handbrake. FYI, I can't use x265 as Plex won't DirectPlay x265 content to my TV/devices and transcoding on the fly eats up all of the CPU and it can't keep up.

My hope is that someone out there can help me in giving some pointers in how fix whatever I'm doing wrong. It's been a long time since I've done any video encoding (circa 2008ish...) and a lot has changed. I remember having to run the video encoding in a cmd window, I'd have to encode the audio separately using some CLI program that started with "ea", and then re-time the subtitles manually and then use something that would merge everything into a mkv file. It's been so long I don't remember in the slightest how I once did all of that. I choose to use Handbrake because it seemed like the easiest option with a GUI. All I remember from way back when is that there was a huge learning curve to encoding video to mkv with all the different tools and frankly, I'm too damn old for that shit again. Unless I have to re-learn it because that's the only way to do it without taking a massive quality hit.

No matter which file I choose for encoding I am having quality issues with blocking/pixelation on every encode. I have spent the last week encoding short 60 second clips for testing with just about every combination of filter/video setting available. I read about MediaInfo and installed it to view the bitrate and other video stream data of the original file that MakeMKV generated from the physical disk. I have set Handbrake to encode at the Avg Bitrate setting as the original file, same framerate, same resolution, with all filters and tunes turned off, and at the "VerySlow" preset. I then pulled up the exact same frame in the original source and the encode in VLC and used the Take Snapshot option under the Video menu.

The difference isn't much in the samples below, but when I start lowering the Avg Bitrate or Constant Quality or turning on any filter/tune, the difference becomes abhorrently worse.

Some info on the machine running the encoding:
Dell R710, Intel Xeon X5670 x2, 24GB RAM, 143GB 10K x8 RAID10.
Windows Server 2016, Build 14393.3025
Handbrake 1.2.2 (2019022300)



First Sample:
Wreck It Ralph

Encode settings in Handbrake:

Code: Select all

Video:
Video Codec: H.264 (x264)
Framerate (FPS): Same as source
Variable Framerate
Avg Bitrate (kbps): 4996
Encoder preset: VerySlow
Encoder Tune: None
Encoder Profile: High
Encoder Level: Auto

Filters:
Detelecine: Off
Interlace Detection: Off
Deinterlace: Off
Denoise: Off
Sharpen: Off
Deblock: Off
Original Source MediaInfo:

Code: Select all

Format                                   : MPEG Video
Bit rate                                 : 4 996 kb/s
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Handbrake encode MediaInfo:

Code: Select all

Format                                   : AVC
Bit rate                                 : 4 996 kb/s
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Encoding settings                        : cabac=1 / ref=16 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=10 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=11 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=8 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=60 / rc=2pass / mbtree=1 / bitrate=4996 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
Original Source screenshot:
Image

Handbrake encode screenshot:
Image

Zoomed Side-by-side:
Image



Second Sample:
Deadpool
WARNING: Censored, but screenshots may be NSFW for some viewers

Encode settings in Handbrake:

Code: Select all

Video:
Video Codec: H.264 (x264)
Framerate (FPS): Same as source
Variable Framerate
Avg Bitrate (kbps): 6271
Encoder preset: VerySlow
Encoder Tune: None
Encoder Profile: High
Encoder Level: Auto

Filters:
Detelecine: Off
Interlace Detection: Off
Deinterlace: Off
Denoise: Off
Sharpen: Off
Deblock: Off
Original Source MediaInfo:

Code: Select all

Format                                   : MPEG Video
Bit rate                                 : 6 271 kb/s
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Handbrake encode MediaInfo:

Code: Select all

Format                                   : AVC
Bit rate                                 : 6 271 kb/s
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Encoding settings                        : cabac=1 / ref=16 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=10 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=11 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=8 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=60 / rc=2pass / mbtree=1 / bitrate=6271 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
Original Source screenshot:
Image

Handbrake encode screenshot:
Image

Zoomed Side-by-side:
Image

Post Reply