Blu-ray Rips, But No Audio Track

Please post here for issues related to Blu-ray discs
Post Reply
drbubba
Posts: 4
Joined: Sat Sep 30, 2017 1:12 am

Blu-ray Rips, But No Audio Track

Post by drbubba » Fri Oct 04, 2019 10:16 pm

I've ripped the Criterion Collection Blu-ray of "Merry Christmas Mr. Lawrence" multiple times, and each time the video rips but the resulting file has no audio track. The ripped file plays perfectly, just no audio. I haven't seen any error messages displayed while ripping the disc. It's worth noting that when playing the disc itself, the audio plays normally. Any idea why this is happening?

oddeyeball
Posts: 24
Joined: Wed Sep 18, 2019 8:20 am

Re: Blu-ray Rips, But No Audio Track

Post by oddeyeball » Fri Oct 04, 2019 10:30 pm

When you select the the video you want to rip, check to see the audio tracks you want are selected. If it is and you're using something like handbrake to shrink the file, make sure handbrake isn't stripping the tracks out, I've made that mistake a few times :lol:

wmcclain
Posts: 29
Joined: Tue Jun 07, 2016 8:23 pm
Contact:

Re: Blu-ray Rips, But No Audio Track

Post by wmcclain » Sun Oct 06, 2019 8:00 pm

Criterion often uses LPCM audio. There was a period a few years ago when Handbrake would not see audio tracks of that type. They corrected it eventually.

I always do "HandBrakeCLI --scan -i " just as a sanity check to see that Handbrake sees what I expect to be there.

-Bill
Capsule film reviews: Strange Picture Scroll

Post Reply