Workflow issue

Please post here for issues related to Blu-ray discs
Post Reply
thirstyspider
Posts: 10
Joined: Sat Jun 04, 2016 12:42 pm

Workflow issue

Post by thirstyspider » Wed Nov 13, 2019 7:53 pm

I've successfully ripped the BluRay trilogy of Kubrick films, and they all use the Windows VC-1 codec for video. The ripped mkv file opens fine in VLC.

When I then put it in Subler to convert subtitles and add metadata, Subler says the video is "unknown".

I realize this isn't a MakeMKV problem, but if anyone has any help they can offer I'd appreciate it. The Subler WIKI didn't offer up much info.

I'm using MacOS 10.14.6, the newest MakeMKV and same for Subler.

Thank you all.

xr200
Posts: 56
Joined: Tue Nov 10, 2015 3:11 am

Re: Workflow issue

Post by xr200 » Wed Nov 13, 2019 9:22 pm

Doesn't "subler" expect an mp4 or m4v (not a mkv) file as input?

thirstyspider
Posts: 10
Joined: Sat Jun 04, 2016 12:42 pm

Re: Workflow issue

Post by thirstyspider » Wed Nov 13, 2019 10:24 pm

I've used this workflow in the past and it's worked fine. It outputs an .m4v for me, though mp4 is another option, as well as others. The issue is it can't read the codec.

Woodstock
Posts: 7641
Joined: Sun Jul 24, 2011 11:21 pm

Re: Workflow issue

Post by Woodstock » Thu Nov 14, 2019 1:57 am

VC-1 is a rather common codec, but there is a variant of it, VC-1 Interlaced, that a number of players do not like.

I've always used handbrake to re-encode video to h264, which fixes a myriad of compatibility issues.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

Post Reply