Drive disappears from windows while creating MKV - "This device does not exist"

Discussion of LibreDrive mode, compatible drives and firmwares
Post Reply
Porkshire
Posts: 4
Joined: Tue Nov 24, 2020 9:41 pm

Drive disappears from windows while creating MKV - "This device does not exist"

Post by Porkshire » Tue Nov 24, 2020 9:50 pm

I've had multiple disks fail (though they do eventually work if I keep trying) with the error similar to below. After this happens, I have to power down the PC, switch off the power supply, wait a little while, and power everything back up to get the drive to work again. If I do not, the drive won't even eject, much less be detected and operational within Windows.

The drive is a WH14NS40. First I used the firmware 'HL-DT-ST-BD-RE_WH16NS60-1.02-NM00100-211810291936.bin' under the "old" folder, because everybody seemed to indicate that 1.02 was the firmware to use. Thinking this might have been an issue, I "upgraded" to 'HL-DT-ST-BD-RE_WH16NS60-1.03-NM00600-212005081010.bin'. This did seem to make things more reliable, but about 50% of the time or more, I still get the errors. Is there anything else I can try? Did I get a bad drive? Did I do something wrong? MakeMKV indicates that LibreDrive is active and everything looks good. I've been able to create several successful 4k MKV files using this drive, but the success rate is very poor.

Error 'OS error - This device does not exist' occurred while reading '/BDMV/STREAM/00026.m2ts' at offset '47915986944'
Error 'OS error - A device which does not exist was specified' occurred while reading '\Device\CdRom0' at offset '47915986944'
Error 'OS error - A device which does not exist was specified' occurred while reading '\Device\CdRom0' at offset '47915986944'
Error 'OS error - A device which does not exist was specified' occurred while reading '\Device\CdRom0' at offset '47915986944'
Error 'OS error - A device which does not exist was specified' occurred while reading '\Device\CdRom0' at offset '47915986944'
Error 'OS error - A device which does not exist was specified' occurred while reading '\Device\CdRom0' at offset '47915986944'
Error 'OS error - This device does not exist' occurred while reading '/BDMV/STREAM/00026.m2ts' at offset '47915986944'
Error 'OS error - This device does not exist' occurred while reading '/BDMV/STREAM/00026.m2ts' at offset '47915986944'
Error 'OS error - This device does not exist' occurred while reading '/BDMV/STREAM/00026.m2ts' at offset '47915986944'
Error 'OS error - This device does not exist' occurred while reading '/BDMV/STREAM/00026.m2ts' at offset '47915986944'
Error 'OS error - This device does not exist' occurred while reading '/BDMV/STREAM/00026.m2ts' at offset '47915986944'
Error 'OS error - This device does not exist' occurred while reading '/BDMV/STREAM/00026.m2ts' at offset '47915986944'
Failed to save title 3 to file <Path removed>
0 titles saved, 1 failed

Porkshire
Posts: 4
Joined: Tue Nov 24, 2020 9:41 pm

Re: Drive disappears from windows while creating MKV - "This device does not exist"

Post by Porkshire » Wed Nov 25, 2020 5:28 pm

Sorry for the double post - can't figure out how to edit the original.

I learned today that a power off/power on is sufficient (didn't need to turn off the power supply), but a reboot is not sufficient to make the drive show up again.

Also here is my information from MakeMKV if that is helpful:
Drive Information
OS device name: D:
Current profile: BD-ROM
Manufacturer: HL-DT-ST
Product: BD-RE WH16NS60
Revision: 1.02
Serial number: KL7K6IG2102
Firmware date: 2118-10-29 19:36
Bus encryption flags: 17
Highest AACS version: 68

LibreDrive Information
Status: Enabled
Drive platform: MT1959
Firmware type: Patched (microcode access re-enabled)
Firmware version: 1.02
DVD all regions: Yes
BD raw data read: Yes
BD raw metadata read: Yes
Unrestricted read speed: Yes

dcoke22
Posts: 379
Joined: Wed Jul 22, 2020 11:25 pm

Re: Drive disappears from windows while creating MKV - "This device does not exist"

Post by dcoke22 » Wed Nov 25, 2020 9:53 pm

I have an actual WH16NS60 with 1.02 firmware on it and I have seen a few times the drive get so confused that it stopped working and seemed to disappear from my Mac. Since mine is external, I can just cycle the power on the optical drive enclosure and it'll come back.

Sometimes, a thorough cleaning of disc has worked. Sometimes, using a different drive I happen to have access to has worked. Sometimes, I've just given up and gotten another disc. I've put several hundred discs through my drive and had this happen less than 10 times, so for me it is very rare.

It is very often the case that cleaning a disc, sometimes more than once, can help a drive finally be able read a troublesome disc.

Porkshire
Posts: 4
Joined: Tue Nov 24, 2020 9:41 pm

Re: Drive disappears from windows while creating MKV - "This device does not exist"

Post by Porkshire » Wed Dec 02, 2020 12:57 am

I got a new drive of the same model and all of the problems went away.

Post Reply