super slow rip

The place to discuss linux version of MakeMKV
Post Reply
bilfrank
Posts: 4
Joined: Tue Nov 13, 2018 2:38 am

super slow rip

Post by bilfrank » Tue Nov 13, 2018 3:15 am

I am using MakeMKV Beta and have been for quite some time now. I have never encountered any issues until very recently when I reinstalled makemkv. Currently it is running under Linux Mint Sylvia, which I wasn't using in the past. My blu ray drive is a Pioneer BD209 version 1.30. I was using a purebred 'buntu before, I think Lubuntu was the last one. Mint seems to handle CD Rom drives a bit, well, oddly in comparison. I installed both the .deb program, as well as compiled the ones from this site here, both with the same results. And have the restricted extras installed as well.

I finally have a successful blu ray conversion, although it took just over 7 hours. I had the debug logging ticked, and will paste those here as well, as there are several debug lines and one 'unspecified' error line which I have no idea what the codes mean. Hopefully you all will.

I did try a standard DVD conversion with MakeMKV as well, and all started out fine running at 10X or 12X or whatever. Then after a few seconds it dropped to .7 or .5 speed for reasons unbeknown to me. That burn it calculated would take some four hours, so I canned it.

And oddly enough, with the exact same DVD and the exact same drive, Handbrake converted the movie in 12 to 15 minutes, making me believe it is not a hardware issue on my end.

Also oddly, with Handbrake, all six of my processors run at 80 to 90 percent, but with MakeMKV they run between 3 and 8 percent.

But anyway, here is the debug output. I would like to figure out what happened, although I am leaning towards an OS issue right now. Just thought I'd post this here before installing MakeMKV on OpenSUSE on a different partition here to see if there are any different results. Would appreciate knowing what happened here.


Debug log started at Mon Nov 12 19:20:23 2018 , written by MakeMKV v1.14.1 linux(x64-release)
Using 262272KB for read cache.
001005:0000 MakeMKV v1.14.1 linux(x64-release) started
001004:0000 Debug logging enabled, log will be saved as /home/bill/MakeMKV_log.txt
001003:0020 DEBUG: Code 0 at I#[NXK&}~:@!_Vs>k%.JaaP:213130122
DEBUG: Code 2365587456 at +tt;G>9(@}L<?d(5:121274285
DEBUG: Code 2365587456 at +tt;G>9(@}L<?d(5:121274285
DEBUG: Code 2365587456 at +tt;G>9(@}L<?d(5:121274285
003007:0000 Using direct disc access mode
005050:0000 Evaluation version, 29 day(s) out of 30 remaining
DEBUG: Code 2365587456 at +tt;G>9(@}L<?d(5:121274285
DEBUG: Code 0 at +tt;G>9(@}L<?d(5:213140403
DEBUG: Code 0 at 2!sV;+`7[8z8bem :213136999
DEBUG: Code 2147483648 at +tt;G>9(@}L<?d(5:29397104
DAFD=PAAAADAAAAEABDQkEEwEBAQ==
DCE=1IGHuRnee3SxmYRpo2oUAEgw3mfEZi0XpFucV4LOChdAW5Wn+yoF+4tAZY+H7X/HK17baQlPWxODCcA157Hzuzqx/Hiy0Oe+5nbpAQ1OGAuZQ74LW8K8hgquycJoMuS+ckDLufH/DTYHEyJZ61AgHzSXihoiWCbzFw==
DCE=KN5PYwUnETzCEYlsmYviDfxgUGBgVavCK9U9+Id2i/VDeGcOukPKQljOTqbXEFOEnyD8DUm6Bvs+GO07gVlxCE82WIO1IVcbFUv0NBjY10pQ5wShSllObMGZ35/Y7fi0iiFOKdvYopw7tk/l38LLWh7M+aLnV+Txiw==
005085:0000 Loaded content hash table, will verify integrity of M2TS files.
DISCID=73BC4AF38802B346C8DED9EFE9806DEFE90738FC
003307:0000 File 00000.mpls was added as title #0
003025:0000 Title #00001.m2ts has length of 44 seconds which is less than minimum title length of 120 seconds and was therefore skipped
003307:0000 File 00002.m2ts was added as title #1
003025:0000 Title #00003.m2ts has length of 61 seconds which is less than minimum title length of 120 seconds and was therefore skipped
003025:0000 Title #00004.m2ts has length of 20 seconds which is less than minimum title length of 120 seconds and was therefore skipped
003025:0000 Title #00007.m2ts has length of 7 seconds which is less than minimum title length of 120 seconds and was therefore skipped
005011:0000 Operation successfully completed
005014:0000 Saving 1 titles into directory /home/bill/Videos
001003:0020 DEBUG: Code 1073741829 at sTxMOJx685gl8Q>i:121262417
004001:0000 Forced subtitles track #4 turned out to be empty and was removed from output file
004001:0000 Forced subtitles track #6 turned out to be empty and was removed from output file
Encountered 1 unclassified errors
error=0x40000005 count=1 name=Posix error - Input/output error
005005:0080 1 titles saved
005036:0104 Copy complete. 1 titles saved.
Application exited at Tue Nov 13 02:01:04 2018

KeithG502
Posts: 1
Joined: Thu Nov 15, 2018 12:27 am

Re: super slow rip

Post by KeithG502 » Thu Nov 15, 2018 1:00 am

I also have experienced slow ripping (DVD main title taking 3+ hours instead of 25 minutes)

Do you have ccextractor installed and defined in Preferences? On a hunch, I removed ccextractor from Preferences and my ripping speed returned to my normal rate.

Upon further investigation I discovered that ccextractor wasn't functioning correctly (missing library). Once I got it working, I added CCExtractor back in Preferences and my rip speed continued at almost my normal rate. There does appear to be some overhead with CCExtractor.

Hope this helps,

KeithG502

bilfrank
Posts: 4
Joined: Tue Nov 13, 2018 2:38 am

Re: super slow rip

Post by bilfrank » Thu Nov 15, 2018 3:27 am

Apparently I don't, the terminal cannot locate a ccextractor nor the Ubuntu cosmic, so I guess it didn't come with the MakeMKV files.

bilfrank
Posts: 4
Joined: Tue Nov 13, 2018 2:38 am

Re: super slow rip

Post by bilfrank » Fri Nov 16, 2018 4:56 am

Well, apparently it was a Mint issue, or even possibly some dependencies that aptitude didn't squawk about. I went ahead and installed MakeMKV on a different partition with SUSE on it, and after chasing down a few library files not notated in a post here, I got a Blu-ray disk done in 21 minutes. Guess maybe after a couple decades, it's just time to hang up the old 'buntu hat, heh.

Thanks, I appreciate you all.

Yorpy
Posts: 1
Joined: Fri Nov 23, 2018 3:32 am

Re: super slow rip

Post by Yorpy » Fri Nov 23, 2018 3:51 am

Posting because I just went through this and it was a pain.
Ubuntu 16_04, MakeMKV 1.14.1
I'm using a "headless" system and was having very slow rips as described along with the messages about ccextractor path whatever.

Here's how to fix it:
Download, compile and install ccextractor. Instructions here: https://github.com/CCExtractor/ccextrac ... ILATION.MD I used the autoconf version, worked smoothly.
Create/edit the MakeMKV settings file. It's probably something like ~/.MakeMKV/settings.conf
In it you need this line:

Code: Select all

app_ccextractor = "/usr/local/bin/ccextractor"
adjusted for your own location, of course. Try

Code: Select all

yorpy@127.0.0.1:~$which ccextractor
if you're not sure.

A reboot couldn't hurt (no idea if required).

Good luck!

old-linux
Posts: 4
Joined: Tue Oct 04, 2016 1:32 am

Re: super slow rip

Post by old-linux » Sun Jan 06, 2019 5:14 pm

I'm running 1.14.2 on an old linux distribution (CentOS 6) and it does work as expected - except it's painfully slow (hours) to read a DVD. Unfortunately I don't think I can build ccextractor because the required dependencies are just not available for this distro. Is there a known workaround that might restore my DVD reading speed to normal? Thanks very much for any thoughts on this.

wmcclain
Posts: 9
Joined: Tue Jun 07, 2016 8:23 pm
Contact:

Re: super slow rip

Post by wmcclain » Mon Jan 07, 2019 1:51 am

If you don't select a closed caption track I don't believe ccextractor needs to be present. If you have slow speed without this sort of track then is must be some other issue.
Capsule film reviews: Strange Picture Scroll

bmillham
Posts: 28
Joined: Mon Mar 27, 2017 12:42 am

Re: super slow rip

Post by bmillham » Mon Jan 07, 2019 5:16 am

I was getting the extremely slow rips, and found that if I unselected the CC track that the rips returned to normal speed.

Post Reply