Pixels Problem in Godzilla: King of the Monsters (2019)

Please post here for issues related to Blu-ray discs
Post Reply
mike_mgoblue
Posts: 106
Joined: Wed Jul 13, 2016 4:36 am

Pixels Problem in Godzilla: King of the Monsters (2019)

Post by mike_mgoblue » Mon Sep 16, 2019 2:25 am

QUESTION: The new 2019 version of Godzilla: King of the Monsters start out with a red "WB" screen that is burning and you hear Godzilla stomping. During this WB intro, there are three times when you see pixels on the screen in the form of square blocks and colors such as neon green. Normally I would be 100% sure this is a technical glitch, but it is happening in a spot where it is "possible" this was done on purpose. Does this happen on your version of this movie?

When I watch the Blu-ray itself in the player, it displays this exact same problem. I had previously been told that problems that might occur with visible "pixels" in a MKV version of the film can potentially be unseen while the disc is "played" in a player. That does not seem to be the case with this movie, which is why I thought it might be an intentional "glitch" to go along with the "stomping" of Godzilla.

Jsauerii
Posts: 4
Joined: Fri Sep 30, 2016 4:03 pm

Re: Pixels Problem in Godzilla: King of the Monsters (2019)

Post by Jsauerii » Sun Oct 06, 2019 2:03 pm

Mine did the same, I came here specifically to see if others had the issue. I haven't seen it again yet and I am about halfway through the movie. Also with it there while watching the blueray as well and how it starts I would think it was intended but then again its worse for me on the disc after that point so who knows.

mike_mgoblue
Posts: 106
Joined: Wed Jul 13, 2016 4:36 am

Re: Pixels Problem in Godzilla: King of the Monsters (2019)

Post by mike_mgoblue » Thu Oct 17, 2019 5:36 am

Thank you.

I'm glad to finally learn someone else has this Blu-ray and sees this same "pixel" problem at the start of the movie during the "WB" screen.

As you describe, these pixels are not visible anywhere else in the movie - only at the start of the moving during the "WB" screen when Godzilla is "stomping." This made me think the visible problem with pixels may be intentional in order to go along with the stomping of Godzilla.

I personally think seeing pixels like that is dumb. If the makers of the movie want to show some interference to go along with the "stomps" of Godzilla, they should show some form of static rather than problems with pixels.

BlueMac77
Posts: 111
Joined: Fri Jul 13, 2018 10:49 pm
Contact:

Re: Pixels Problem in Godzilla: King of the Monsters (2019)

Post by BlueMac77 » Thu Oct 17, 2019 7:22 am

mike_mgoblue wrote:
Thu Oct 17, 2019 5:36 am
Thank you.

I'm glad to finally learn someone else has this Blu-ray and sees this same "pixel" problem at the start of the movie during the "WB" screen.

As you describe, these pixels are not visible anywhere else in the movie - only at the start of the moving during the "WB" screen when Godzilla is "stomping." This made me think the visible problem with pixels may be intentional in order to go along with the stomping of Godzilla.

I personally think seeing pixels like that is dumb. If the makers of the movie want to show some interference to go along with the "stomps" of Godzilla, they should show some form of static rather than problems with pixels.
Mine also had the "Green Pixels' at the intro part. I have 2 copies of Godzilla KOTMonsters 4K/Blu-Ray, one from Walmart and the other from Amazon. They both had the "Pixels". Yeah, I think the "Pixels" are not necessary and does not contribute to the creative aspect.

Post Reply